Bug 816823 - traceback when /boot is on md on EFI
traceback when /boot is on md on EFI
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:cd614374160db554007cf9c64e2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 02:00 EDT by Michael Glasgow
Modified: 2012-05-16 07:51 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-17.27-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 07:51:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-p_F0Nd (1.51 MB, text/plain)
2012-04-27 02:00 EDT, Michael Glasgow
no flags Details

  None (edit)
Description Michael Glasgow 2012-04-27 02:00:17 EDT
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-p_F0Nd
hashmarkername: anaconda
kernel:         3.3.0-1.fc17.x86_64
other involved packages: 
product:        Fedora
release:        Cannot get release name.
time:           Fri 27 Apr 2012 01:03:43 AM CDT
version:        17-Beta

anaconda-tb-p_F0Nd: Binary file, 1578890 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.20 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1132, in grub_device_name
:    name = "(hd%d" % self.drives.index(drive)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1491, in grub_conf_device_line
:    return "device %s %s\n" % (self.grub_device_name(self.stage2_device),
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1258, in write_config_header
:    config.write(self.grub_conf_device_line)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1037, in write_config
:    self.write_config_header(config)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1374, in write_config
:    super(GRUB, self).write_config()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1558, in write
:    self.write_config()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2346, in writeBootloader
:    anaconda.bootloader.write()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 247, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1201, in nextClicked
:    self.anaconda.dispatch.go_forward()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/progress_gui.py", line 79, in renderCallback
:    self.intf.icw.nextClicked()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1221, in handleRenderCallback
:    self.currentWindow.renderCallback()
:ValueError: MDRaidArrayDevice instance (0x7f2d2cba9ed0) --
:  name = md0  status = True  kids = 0 id = 126
:  parents = ['existing 368MB partition sda2 (115) with non-existent mdmember',
: 'existing 368MB partition sdb2 (111) with non-existent mdmember']
:  uuid = eb1d1595:a14545aa:42f30dc8:1a7f8301  size = 367.98828125
:  format = existing ext4 filesystem mounted at /boot
:  major = 0  minor = 0  exists = True  protected = False
:  sysfs path = /devices/virtual/block/md0  partedDevice = parted.Device instance --
:  model: Linux Software RAID Array  path: /dev/md0  type: 17
:  sectorSize: 512  physicalSectorSize:  512
:  length: 753640  openCount: 0  readOnly: False
:  externalMode: False  dirty: False  bootDirty: False
:  host: 13107  did: 13107  busy: True
:  hardwareGeometry: (94205, 2, 4)  biosGeometry: (46, 255, 63)
:  PedDevice: <_ped.Device object at 0x7f2d2c31d560>
:  target size = 0  path = /dev/md0
:  format args = None  originalFormat = ext4  level = 1  spares = 0
:  members = 2
:  total devices = 2  metadata version = 1.0 is not in list

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:TZ=America/Chicago
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.9J3cLA
:LVM_SUPPRESS_FD_WARNINGS=1
:PWD=/
:MALLOC_PERTURB_=204
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1
Comment 1 Michael Glasgow 2012-04-27 02:00:44 EDT
Created attachment 580640 [details]
File: anaconda-tb-p_F0Nd
Comment 2 Michael Glasgow 2012-04-27 02:15:38 EDT
Straightforward installation of F17 on a new Thinkpad T420, using LVM on crypto on MD.
Comment 3 Michael Glasgow 2012-05-07 15:52:47 EDT
Digging a little further, it looks like this exception occurs whenever /boot is on an MD device in EFI mode.  In this case I was trying to install with /boot on /dev/md0.  Is there some reason this shouldn't work?

I think it would occur regardless of whether LVM/crypto were in use for the rest of the system.
Comment 4 David Lehman 2012-05-11 12:08:31 EDT
This is totally untested, so we're probably going to just disable /boot on md on EFI for F17 since it's too late to be trying to test/fix it.
Comment 5 Fedora Update System 2012-05-14 14:40:42 EDT
anaconda-17.27-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.27-1.fc17
Comment 6 Fedora Update System 2012-05-14 22:31:07 EDT
Package anaconda-17.27-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.27-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7834/anaconda-17.27-1.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-05-16 07:51:49 EDT
anaconda-17.27-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.