Bug 816839 - data overflow error when debug progress -1
Summary: data overflow error when debug progress -1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-27 07:12 UTC by Yuyu Zhou
Modified: 2013-02-21 08:38 UTC (History)
5 users (show)

Fixed In Version: libguestfs-1.16.30-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 08:38:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0324 0 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2013-02-20 20:54:42 UTC

Description Yuyu Zhou 2012-04-27 07:12:39 UTC
Description of problem:
data overflow error when debug progress -1.

Version-Release number of selected component (if applicable):
libguestfs-1.16.19-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
# guestfish
> add test.raw
> run
> debug progress -1

Actual result:
A process bar with 119438h shows up.

Expected result:
Proper error message pops.

Additional info:

Comment 1 Richard W.M. Jones 2012-04-27 07:40:45 UTC
debug progress is an unsupported debug API.  I'll put
in a patch to fix this, but it's not high on my
priority for RHEL.

Comment 2 Richard W.M. Jones 2012-04-27 14:39:00 UTC
Fixed upstream in commit
cc798540370658ecc1bba94c4ab4b64485c9bcc6.

><fs> debug progress -1
libguestfs: error: debug: progress: argument is 0, less than 0, or too large
><fs> debug progress -100
libguestfs: error: debug: progress: argument is 0, less than 0, or too large
><fs> debug progress 1000000000
libguestfs: error: debug: progress: argument is 0, less than 0, or too large
><fs> debug progress 0
libguestfs: error: debug: progress: argument is 0, less than 0, or too large
><fs> debug progress 10
 100% ⟦▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓⟧ 00:00
ok

Comment 3 RHEL Program Management 2012-07-10 06:19:05 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 RHEL Program Management 2012-07-10 23:48:40 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 6 Wei Shi 2012-11-01 08:21:26 UTC
Reproduced:
libguestfs-1.16.19-1.el6.x86_64

# guestfish 

Welcome to guestfish, the libguestfs filesystem interactive shell for
editing virtual machine filesystems.

Type: 'help' for help on commands
      'man' to read the manual
      'quit' to quit the shell

><fs> add test.raw
><fs> run
 100% ⟦▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓⟧ 00:00
><fs> debug progress -1
◐  0% ⟦══════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════⟧ >12083◓  0% ⟦══════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════⟧ >12079
◑  0% ⟦══════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════════⟧ >12076




Verified:
libguestfs-1.16.32-2.el6.x86_64
# guestfish 

Welcome to guestfish, the libguestfs filesystem interactive shell for
editing virtual machine filesystems.

Type: 'help' for help on commands
      'man' to read the manual
      'quit' to quit the shell

><fs> add RHEL-Server-5.9-64-pv.raw
><fs> run
><fs> debug progress -1
libguestfs: error: debug: progress: argument is 0, less than 0, or too large
><fs> debug progress -100
libguestfs: error: debug: progress: argument is 0, less than 0, or too large
><fs> debug progress 1000000000
libguestfs: error: debug: progress: argument is 0, less than 0, or too large
><fs> debug progress 0
libguestfs: error: debug: progress: argument is 0, less than 0, or too large
><fs> debug progress 10
 100% ⟦▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓⟧ 00:00
ok
><fs>

Comment 8 errata-xmlrpc 2013-02-21 08:38:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0324.html


Note You need to log in before you can comment on or make changes to this bug.