Bug 816854 - fc17 beta cd install drops to dracut on boot with grub 1: "can't mount root"
fc17 beta cd install drops to dracut on boot with grub 1: "can't mount root"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 04:14 EDT by zeus_001_
Modified: 2012-07-03 04:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-03 04:22:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda, dracut and dmesg logs (173.03 KB, application/x-gzip)
2012-04-27 04:14 EDT, zeus_001_
no flags Details

  None (edit)
Description zeus_001_ 2012-04-27 04:14:56 EDT
Created attachment 580672 [details]
anaconda, dracut and dmesg logs

Description of problem:
Just installed FC17 Beta from cd a number of times (selecting the Software Development group). I've tried both letting the install set up partitions and doing it manually.
Grub2 fails to install properly giving an error near the end of the install (grub config and directory appears in boot
partition, but loads with a single flashing cursor/underline and nothing
happens).
I install grub 1 with no issues using a FC15 CD instead to boot (couldn't find a way to use fc17 cd as live).
All installs result in dropping to dracut shell just after kernel loads, with
warnings:

dracut Warning: /sysroot has no proper rootfs layout, ignoring and removing
offending mount hook
dracut Warning: can't mount root filesystem

all drives and partitions are visible, mounting manually within dracut is not an issue

Version-Release number of selected component (if applicable):
kernel version 3.3.0-1
(no obvious method to print dracut version)

How reproducible:
every time

Steps to Reproduce:
1. install fc17 beta from cd. (receive bootloader error message)
2. install grub1, write mbr and create grub.conf
3. try to boot
  
Actual results:
drops to dracut shell

Expected results:
fedora boots
Comment 1 ozkan89 2012-05-26 10:22:02 EDT
Hello,

I almost spend 4 hours to understand what is going with this.
Then I run a debug application and I found the reason:

It seems that the Fedora developers fucked with their mothers, so they 
did a mistake while build that beta iso.. simples!
Comment 2 Harald Hoyer 2012-05-29 10:54:17 EDT
(In reply to comment #0)
> Created attachment 580672 [details]
> anaconda, dracut and dmesg logs
> 
> Description of problem:
> Just installed FC17 Beta from cd a number of times (selecting the Software
> Development group). I've tried both letting the install set up partitions
> and doing it manually.
> Grub2 fails to install properly giving an error near the end of the install
> (grub config and directory appears in boot
> partition, but loads with a single flashing cursor/underline and nothing
> happens).
> I install grub 1 with no issues using a FC15 CD instead to boot (couldn't
> find a way to use fc17 cd as live).
> All installs result in dropping to dracut shell just after kernel loads, with
> warnings:
> 
> dracut Warning: /sysroot has no proper rootfs layout, ignoring and removing
> offending mount hook
> dracut Warning: can't mount root filesystem
> 
> all drives and partitions are visible, mounting manually within dracut is
> not an issue
> 
> Version-Release number of selected component (if applicable):
> kernel version 3.3.0-1
> (no obvious method to print dracut version)
> 
> How reproducible:
> every time
> 
> Steps to Reproduce:
> 1. install fc17 beta from cd. (receive bootloader error message)
> 2. install grub1, write mbr and create grub.conf
> 3. try to boot
>   
> Actual results:
> drops to dracut shell
> 
> Expected results:
> fedora boots

hmm, you can try "root=/dev/sda4" and boot without any initramfs

Note You need to log in before you can comment on or make changes to this bug.