Bug 816861 - Installed RPM does not update the PATH to the binaries
Installed RPM does not update the PATH to the binaries
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openmpi (Show other bugs)
16
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 04:21 EDT by Trent
Modified: 2012-04-27 08:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 08:35:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trent 2012-04-27 04:21:59 EDT
Description of problem:

Upon installation of Open MPI, typing in one of the commands results in "command not found"

Others in the OpenMPI mailing list using Fedora have been complaing of this too.

Version-Release number of selected component (if applicable):

1.5.4

How reproducible:

type in one of the Open MPI commands

Steps to Reproduce:
1. While in a shell...
2. enter any one of the commands available e.g. "mpirun a.out"
3.
  
Actual results:

COMMAND NOT FOUND 

Expected results:

Execution of compiled binary.

Additional info:
Comment 1 Doug Ledford 2012-04-27 08:35:57 EDT
This is not a bug.  Please pass on to people on the mailing list that the Fedora MPI packaging guidelines specifically call out that there should be no default MPI implementation, and that each user should use the environment-modules facility to load the proper configuration for their selected MPI implementation.  This is part of our support for having multiple MPI instances installed and operational at the same time.

Note You need to log in before you can comment on or make changes to this bug.