Bug 816870 - Bonnie on stripe sanity is very slow
Bonnie on stripe sanity is very slow
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: stripe (Show other bugs)
pre-release
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: shishir gowda
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-04-27 04:37 EDT by shylesh
Modified: 2013-12-08 20:31 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:16:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 3.3.0qa41
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
valgrind logs for stripe sanity bonnie testt (191.61 KB, text/x-log)
2012-04-27 04:38 EDT, shylesh
no flags Details
valgrind logs for bricks (450.00 KB, application/x-tar)
2012-04-27 06:15 EDT, shylesh
no flags Details
statedump (40.00 KB, application/x-tar)
2012-04-27 06:18 EDT, shylesh
no flags Details

  None (edit)
Description shylesh 2012-04-27 04:37:51 EDT
Description of problem:
Bonnie is taking 12 hours to finish on stripe volume

Version-Release number of selected component (if applicable):



This is because of the memory leak.  attached the valgrind logs
Comment 1 shylesh 2012-04-27 04:38:21 EDT
Created attachment 580673 [details]
valgrind logs for stripe sanity bonnie testt
Comment 2 shylesh 2012-04-27 06:15:15 EDT
Created attachment 580707 [details]
valgrind logs for bricks
Comment 3 shylesh 2012-04-27 06:18:15 EDT
Created attachment 580708 [details]
statedump
Comment 4 Anand Avati 2012-04-27 13:51:09 EDT
CHANGE: http://review.gluster.com/3240 (storage/posix: Fix leak of dict in getxattr calls.) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 5 shylesh 2012-05-17 09:26:37 EDT
Fixed the memleak in posix_getxattr

Note You need to log in before you can comment on or make changes to this bug.