Bug 816889 - eclipse-cdt libhover misses documentation
eclipse-cdt libhover misses documentation
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
17
All Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 05:05 EDT by Krzysztof Daniel
Modified: 2014-01-12 19:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 10:12:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Daniel 2012-04-27 05:05:09 EDT
What steps will reproduce the problem?
1. Install Eclipse, CDT and DTP. Delete local .eclipse folder.
2. Switch to DTP perspective, try to create new database connection
3. Press Help icon in the dialog
4. The help will try to index the documentation, and will fail.


-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help documentation could not be indexed completely.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base
Session Data:
eclipse.buildId=I20120417-1000
java.version=1.7.0_b147-icedtea
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64


-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/gconf/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.datatools.doc.isv/html/reference/extension-points/org_eclipse_datatools_connectivity_oda_datasource.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.datatools.doc.isv/html/reference/extension-points/org_eclipse_datatools_connectivity_oda_design_ui_datasource.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/pango/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/gdk-pixbuf/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/p11-kit/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/telepathy-farsight/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/mission-control-plugins/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/libxml2/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/libcanberra/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.datatools.doc.isv/html/reference/extension-points/org_eclipse_datatools_sqltools_routineeditor_documentprovider.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/libgnome/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/pygtkspell/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.mylyn.help.ui/doc/notices.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/libbonobo/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/gnome-vfs-2.0/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/atk/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/libsoup-2.4/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/farsight2-libs-0.10/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/telepathy-glib/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/ORBit2/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/libnotify/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/farsight2-plugins-0.10/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/dbus-glib/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/pygnomevfs/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/telepathy-logger/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/gobject/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/glib/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/at-spi-cspi/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/gio/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/cairo/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base

-- Error Details --
Date: Fri Apr 27 10:58:36 CEST 2012
Message: Help document /org.eclipse.linuxtools.cdt.libhover.devhelp/bonobo-activation/index.html cannot be opened.
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.help.base
Comment 1 Jeff Johnston 2012-05-04 16:04:47 EDT
I am trying to reproduce this, but cannot.  I updated the "Fedora Eclipse" group in my F17 VM and removed my .eclipse directory.  I went into the Database Development perspective, right-clicked on Database Connections and selected New....  In the wizard, I hit the question mark, but I got nothing to pop up but I do not see any errors in the Error Console.

Did I miss some step or has the problem simply gone away/changed due to package updates?
Comment 2 Alexander Kurtakov 2012-06-12 17:48:00 EDT
Chris would you please help Jeff reproducing the problem?
Comment 3 Krzysztof Daniel 2012-06-14 10:12:06 EDT
I have just tried again. It looks like the problem is gone (and help pages are where expected).

Note You need to log in before you can comment on or make changes to this bug.