Bug 816900 - There is a flash screen when move up and down between pages.
There is a flash screen when move up and down between pages.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: ZStream
: 876518 (view as bug list)
Depends On:
Blocks: 783549 883400 894341
  Show dependency treegraph
 
Reported: 2012-04-27 05:24 EDT by Guohua Ouyang
Modified: 2016-04-26 10:27 EDT (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-11.el6
Doc Type: Bug Fix
Doc Text:
When loading the Red Hat Network (RHN) screen the Red Hat Enterprise Virtualization Hypervisor previously used the rhn_check command to determine whether the machine was registered to RHN. This led to delays on systems with slow network connections. As a result the screen appeared to flicker when loading the RHN configuration screen. The hypervisor now checks the local file system to determine whether the system is registered to RHN, eliminating the delay.
Story Points: ---
Clone Of:
: 894341 (view as bug list)
Environment:
Last Closed: 2013-02-28 11:30:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guohua Ouyang 2012-04-27 05:24:58 EDT
Description of problem:
When move up and down between pages, there is a  flash screen. It's more
obviously when move from Security -> Network -> status,  oVirt Engine ->
Red Hat Network.
Sometimes can see there is text on the flash screen.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120419.0.el6

How reproducible:
100%


Steps to Reproduce:
1. move up and down between pages
 
Actual results:
There is a flash screen when move up and down between pages.

Expected results:
No flash screen when move up and down between pages, or make it
unnoticeable.
Comment 16 Mike Burns 2012-11-08 03:46:23 EST
I think we should be consistent and show it on all translations.
Comment 17 Fabian Deutsch 2012-11-12 09:25:55 EST
Okay. The following patch enables the loading message for all transitions:

http://gerrit.ovirt.org/9188
Comment 19 Mike Burns 2012-11-14 08:20:29 EST
*** Bug 876518 has been marked as a duplicate of this bug. ***
Comment 27 Ashish 2012-12-05 07:56:04 EST
I have verified the fix and able to see "loading" whenever we move from one page to other. 
But from user experience point of view older implementation was much better. The issue was seen mostly when we use to navigate to & from network options. Now we see the message "loading" for all the options which is causing a while navigation for all the operations.
Comment 29 Fabian Deutsch 2012-12-10 04:21:28 EST
The check is now file-based  which makes the page-loading significantly faster.

http://gerrit.ovirt.org/#/c/9754/

Tested as follows:

1. Install with applied patch
2. Register to satellite server
3. Switch between pages is fast and /etc/sysconfig/rhn/systemid exists
Comment 30 Fabian Deutsch 2012-12-10 06:28:43 EST
(In reply to comment #27)
> I have verified the fix and able to see "loading" whenever we move from one
> page to other. 
> But from user experience point of view older implementation was much better.
> The issue was seen mostly when we use to navigate to & from network options.
> Now we see the message "loading" for all the options which is causing a
> while navigation for all the operations.

I've added a minimum display time of 300ms to the "loading message" to give the user an idea of what the text says.
We can remove this delay but then a short display time can be seen as flickering and raise the feeling of missing something (the text appears but can not be read fast enough to understand what it says).
Comment 32 Ashish 2012-12-10 23:42:26 EST
(In reply to comment #29)
> The check is now file-based  which makes the page-loading significantly
> faster.
> 
> http://gerrit.ovirt.org/#/c/9754/
> 
> Tested as follows:
> 
> 1. Install with applied patch
> 2. Register to satellite server
> 3. Switch between pages is fast and /etc/sysconfig/rhn/systemid exists


Will this patch gone get included in RHEL6.4 Hypervisor? If yes then please let us know which release?
Comment 33 Mike Burns 2012-12-11 09:32:15 EST
Yes, it will be included in 6.4 RHEV-H.  It will should be included in one of the beta refreshes, but it's unclear at the moment which one.
Comment 38 Ashish 2013-02-01 00:58:50 EST
Verified with RHEL6.4-S4-Hypervisor (rhevh-6.4-20130116.3.0).
Works fine. Can see the loading message.
Comment 40 errata-xmlrpc 2013-02-28 11:30:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.