This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 816915 - abort after an interrupted replace-brick operation causes glusterd to hang
abort after an interrupted replace-brick operation causes glusterd to hang
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: krishnan parthasarathi
: Triaged
: 787123 797729 818519 (view as bug list)
Depends On:
Blocks: 852307 996047
  Show dependency treegraph
 
Reported: 2012-04-27 06:00 EDT by Raghavendra G
Modified: 2015-11-03 18:04 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 852307 (view as bug list)
Environment:
Last Closed: 2015-05-14 13:25:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Raghavendra G 2012-04-27 06:00:47 EDT
Description of problem:

If source brick was killed while replace-brick operation in progress, a subsequent replace-brick abort will result in hang of glusterd. Though glusterd seems to be in _Interruptible sleep_ ('S' state of ps output), one cannot attach gdb or strace to glusterd process. Even other commands on gluster-cli fail. However attaching strace to glusterd process even before abort was attempted showed that glusterd to be hung in lsetxattr syscall. A statedump of client - a maintainance mount - and src brick revealed that setxattr call to be stuck in pump translator.

Code analysis with KP pointed the cause to crawl operation not being started after restart of brick.

Version-Release number of selected component (if applicable):

8b6534031ab9b60da293e9c2ffb95141d714f973

How reproducible: Consistently


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 krishnan parthasarathi 2012-05-03 03:17:49 EDT
*** Bug 787123 has been marked as a duplicate of this bug. ***
Comment 2 Amar Tumballi 2012-07-11 02:23:08 EDT
patch sent @ http://review.gluster.com/3264
Comment 3 krishnan parthasarathi 2012-07-11 03:11:18 EDT
*** Bug 818519 has been marked as a duplicate of this bug. ***
Comment 4 krishnan parthasarathi 2012-07-11 03:19:27 EDT
*** Bug 797729 has been marked as a duplicate of this bug. ***
Comment 5 Vijay Bellur 2013-01-04 11:50:02 EST
CHANGE: http://review.gluster.org/3275 (glusterd: Made dst brick's port info available to all peers) merged in master by Vijay Bellur (vbellur@redhat.com)
Comment 6 Niels de Vos 2014-09-22 08:31:06 EDT
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/
Comment 7 Niels de Vos 2015-05-14 13:25:49 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 8 Niels de Vos 2015-05-14 13:28:04 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 9 Niels de Vos 2015-05-14 13:35:12 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.