Bug 816981 - yppasswdd doesn't handle crypt() returning NULL
yppasswdd doesn't handle crypt() returning NULL
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ypserv (Show other bugs)
6.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Honza Horak
Tomas Dolezal
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 07:43 EDT by Honza Horak
Modified: 2013-02-21 03:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:43:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch hanlding crypt() returning NULL (955 bytes, patch)
2012-04-27 07:48 EDT, Honza Horak
no flags Details | Diff

  None (edit)
Description Honza Horak 2012-04-27 07:43:17 EDT
Description of problem:
yppasswd doesn't handle crypt() returning NULL, which is possible in fips mode
and other corner conditions. It blindly tries to strcmp the returned
values of crypt()

--- Additional comment via e-mail from sgrubb@redhat.com on 2012-04-23 23:19:48
EDT ---

The Single Unix Spec documents crypt() as being able to return NULL under
certain conditions that are not related to FIPS. So, all software needs to
handle this possibility. But there have been some recent changes in glibc that
make it more likely that you will hit this. Especially if the user can control
the input. I'd update everywhere that you can get a QE slot. RHEL5 FIPS support
is supposed to be good. But I don't know if the glibc developers also updated
it in a way that makes this more likely now.

Version-Release number of selected component (if applicable):
ypserv-2.19-22.el6

Additional info:
Similar bug is in yp-tools: bug#816201
Comment 1 Honza Horak 2012-04-27 07:48:41 EDT
Created attachment 580741 [details]
patch hanlding crypt() returning NULL
Comment 3 RHEL Product and Program Management 2012-10-12 07:50:50 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 9 errata-xmlrpc 2013-02-21 03:43:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0330.html

Note You need to log in before you can comment on or make changes to this bug.