Bug 816984 - yppasswdd doesn't handle crypt() returning NULL
yppasswdd doesn't handle crypt() returning NULL
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ypserv (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Honza Horak
qe-baseos-daemons
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 07:50 EDT by Honza Horak
Modified: 2013-03-13 13:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-13 13:42:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch hanlding crypt() returning NULL (955 bytes, patch)
2012-04-27 07:52 EDT, Honza Horak
no flags Details | Diff

  None (edit)
Description Honza Horak 2012-04-27 07:50:00 EDT
Description of problem:
yppasswdd doesn't handle crypt() returning NULL, which is possible in fips mode
and other corner conditions. It blindly tries to strcmp the returned
values of crypt()

--- Additional comment via e-mail from sgrubb@redhat.com on 2012-04-23 23:19:48
EDT ---

The Single Unix Spec documents crypt() as being able to return NULL under
certain conditions that are not related to FIPS. So, all software needs to
handle this possibility. But there have been some recent changes in glibc that
make it more likely that you will hit this. Especially if the user can control
the input. I'd update everywhere that you can get a QE slot. RHEL5 FIPS support
is supposed to be good. But I don't know if the glibc developers also updated
it in a way that makes this more likely now.

Version-Release number of selected component (if applicable):
ypserv-2.19-9.el5_8.1

Additional info:
Similar bug is in yp-tools: bug#816203
Comment 1 Honza Horak 2012-04-27 07:52:29 EDT
Created attachment 580742 [details]
patch hanlding crypt() returning NULL
Comment 2 RHEL Product and Program Management 2012-06-11 21:15:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 Honza Horak 2013-03-13 13:42:10 EDT
There is no chance to fix this in RHEL-5 any more, since RHEL 5.10 is going to include only serious fixes.

Note You need to log in before you can comment on or make changes to this bug.