Bug 816988 - Please include upstream patch for GCC 4.7
Please include upstream patch for GCC 4.7
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ice (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Haïkel Guémar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 08:02 EDT by Mary Ellen Foster
Modified: 2012-06-25 20:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 20:40:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modified version of upstream patch (43.51 KB, patch)
2012-05-11 09:59 EDT, Mary Ellen Foster
no flags Details | Diff

  None (edit)
Description Mary Ellen Foster 2012-04-27 08:02:36 EDT
Description of problem:
ZeroC upstream has provided a patch that fixes compilation with GCC 4.7 and other recent compilers:
    http://www.zeroc.com/forums/attachments/patches/968d1329271168-patch-compiling-ice-clang-gcc4-7-ice_for_clang.txt

Please apply this patch to the Fedora packages. If not, you get the bug described here on Fedora 17:
    http://www.zeroc.com/forums/bug-reports/5709-problem-ami-gcc-4-7-a.html#post24868

Version-Release number of selected component (if applicable):
ice-3.4.2-12.fc17

How reproducible:
Every time

Steps to Reproduce:
(See above forum posting)
Comment 1 Mary Ellen Foster 2012-05-09 10:35:25 EDT
I see that the upCast related patch was apparently applied in version 3.4.2-11. Regardless, I still get failures building on Fedora 17. :(
Comment 2 Mary Ellen Foster 2012-05-11 09:59:26 EDT
Created attachment 583855 [details]
Modified version of upstream patch

Here's a slightly modified version of the upstream patch from http://www.zeroc.com/forums/patches/5647-patch-compiling-ice-clang-gcc4-7-a.html -- basically, it adds __linux to the list of #ifdefs in three places, and is otherwise unchanged. With this patch, I no longer see any problems with GCC 4.7 on Fedora 17.

This should replace the existing Patch1, Patch7, and Patch8 from the srpm.

I also note that the current SRPM contains a Patch9 which is not currently being applied as part of the build -- is that a problem?
Comment 3 Mary Ellen Foster 2012-05-21 05:12:00 EDT
Ping -- any chance of updated packages? At the moment, ice is actually broken on F17 (due to this and to bug 812156) ...
Comment 4 Haïkel Guémar 2012-05-21 05:15:59 EDT
I'm working on that, though ice build time doesn't help. :]
Comment 5 Fedora Update System 2012-05-28 04:35:40 EDT
ice-3.4.2-13.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ice-3.4.2-13.fc17
Comment 6 Fedora Update System 2012-05-29 06:26:34 EDT
Package ice-3.4.2-13.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ice-3.4.2-13.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8533/ice-3.4.2-13.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-05-29 11:38:20 EDT
ice-3.4.2-14.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ice-3.4.2-14.fc17
Comment 8 Fedora Update System 2012-06-12 09:58:07 EDT
ice-3.4.2-15.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ice-3.4.2-15.fc17
Comment 9 Fedora Update System 2012-06-25 20:40:21 EDT
ice-3.4.2-15.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.