Bug 817023 - "mdadm --monitor" crashes when resync finishes
"mdadm --monitor" crashes when resync finishes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jes Sorensen
Fedora Extras Quality Assurance
:
: 816527 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 09:11 EDT by Jes Sorensen
Modified: 2012-07-11 19:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 22:48:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jes Sorensen 2012-04-27 09:11:05 EDT
Description of problem:
"mdadm --monitor" crashes when resync finishes.

Version-Release number of selected component (if applicable):
mdadm v3.2.3

How reproducible:
Frequently

Steps to Reproduce:
1. Start mdadm monitor daemon
mdadm --monitor --scan --daemonize -y -m root@localhost --delay=1

2. Create container and redundant array
mdadm -C /dev/md/imsm0 -amd -e imsm -n 4 /dev/sda /dev/sdb /dev/sdc /dev/sdd -R
mdadm -C /dev/md/vol -amd -l5 --chunk 64 --size $[2*1024*1024] -n3 /dev/sda
/dev/sdb /dev/sdc -R -f

3. Wait for end of resync.
4. Check if mdadm monitor is running.

Actual results:
mdadm monitor crashes

Expected results:
mdadm monitor should run in the background and report events by sending emails
and logging to system log.

Additional info:
This bug is fixed by patch in Neil's repo:
commit: 8453f8d0df0111cfd25e984afb7a64153b04bc27
http://neil.brown.name/git?p=mdadm;a=commitdiff;h=8453f8d0df0111cfd25e984afb7a64153b04bc27
Comment 1 Fedora Update System 2012-05-02 06:09:16 EDT
mdadm-3.2.3-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mdadm-3.2.3-9.fc17
Comment 2 Fedora Update System 2012-05-02 06:15:19 EDT
mdadm-3.2.3-9.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mdadm-3.2.3-9.fc16
Comment 3 Fedora Update System 2012-05-02 06:19:09 EDT
mdadm-3.2.3-9.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mdadm-3.2.3-9.fc15
Comment 4 Fedora Update System 2012-05-02 16:34:14 EDT
Package mdadm-3.2.3-9.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mdadm-3.2.3-9.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7105/mdadm-3.2.3-9.fc17
then log in and leave karma (feedback).
Comment 5 Jes Sorensen 2012-05-04 09:16:09 EDT
*** Bug 816527 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2012-05-10 10:48:37 EDT
mdadm-3.2.4-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mdadm-3.2.4-2.fc17
Comment 7 Fedora Update System 2012-05-10 10:51:14 EDT
mdadm-3.2.4-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mdadm-3.2.4-2.fc16
Comment 8 Fedora Update System 2012-05-10 10:54:00 EDT
mdadm-3.2.4-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mdadm-3.2.4-2.fc15
Comment 9 Fedora Update System 2012-05-15 12:36:04 EDT
mdadm-3.2.4-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mdadm-3.2.4-3.fc17
Comment 10 Fedora Update System 2012-05-15 12:42:28 EDT
mdadm-3.2.4-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mdadm-3.2.4-3.fc16
Comment 11 Fedora Update System 2012-05-15 12:47:10 EDT
mdadm-3.2.4-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mdadm-3.2.4-3.fc15
Comment 12 Fedora Update System 2012-05-21 11:07:54 EDT
mdadm-3.2.5-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mdadm-3.2.5-1.fc17
Comment 13 Fedora Update System 2012-05-21 11:14:08 EDT
mdadm-3.2.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mdadm-3.2.5-1.fc16
Comment 14 Fedora Update System 2012-05-21 11:19:44 EDT
mdadm-3.2.5-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mdadm-3.2.5-1.fc15
Comment 15 Fedora Update System 2012-06-06 22:48:34 EDT
mdadm-3.2.5-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-06-06 22:51:48 EDT
mdadm-3.2.5-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2012-06-26 03:16:05 EDT
mdadm-3.2.5-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mdadm-3.2.5-3.fc17
Comment 18 Fedora Update System 2012-07-11 19:53:59 EDT
mdadm-3.2.5-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.