This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 817035 - Seam 2.2: JBoss Cache Seam Cache provider cannot be used on EAP6
Seam 2.2: JBoss Cache Seam Cache provider cannot be used on EAP6
Status: CLOSED CANTFIX
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
2.0.0.GA
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Marek Novotny
Seam2.2
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 09:33 EDT by Marek Schmidt
Modified: 2012-07-17 15:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
JBoss Cache is not supported on Enterprise Application Platform 6, which causes JBoss Cache Seam Cache provider to fail in a Seam application on the application server.
Story Points: ---
Clone Of:
Environment:
2.2.5.EAP5 (included in EAP 5.1.2.GA)
Last Closed: 2012-06-18 11:32:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP-8850 Major Closed Backport Seam Infinispan Cache Provider to Seam 2.2 2013-05-13 10:47:35 EDT

  None (edit)
Description Marek Schmidt 2012-04-27 09:33:26 EDT
JBoss Cache doesn't work on EAP6 and therefore JBoss Cache Seam Cache provider cannot be used in a Seam application on EAP6.

Attempting to use JBoss Cache on EAP6 fails with

Caused by: java.lang.NoClassDefFoundError: org/jboss/util/xml/JBossEntityResolver
        at org.jboss.cache.config.parsing.RootElementBuilder.<clinit>(RootElementBuilder.java:51) [jbosscache-core.jar:3.2.8.GA]
        at org.jboss.cache.config.parsing.XmlConfigurationParser.<init>(XmlConfigurationParser.java:93) [jbosscache-core.jar:3.2.8.GA]
        at org.jboss.cache.DefaultCacheFactory.createCache(DefaultCacheFactory.java:170) [jbosscache-core.jar:3.2.8.GA]
        at org.jboss.seam.cache.JbossCache3Provider.create(JbossCache3Provider.java:66) [jboss-seam.jar:2.2.5.EAP5]
        ... 61 more
Caused by: java.lang.ClassNotFoundException: org.jboss.util.xml.JBossEntityResolver from [Module "deployment.jboss-seam-blog.ear:main" from Service Module Loader]
        at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
        at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
        ... 65 more
Comment 1 Rebecca Newton 2012-05-13 21:35:39 EDT
Thanks for the bug, please check the technical notes field for accuracy.
Comment 2 Rebecca Newton 2012-05-13 21:35:39 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
JBoss Cache is broken on Enterprise Application Platform 6, which causes JBoss Cache Seam Cache provider to fail in a Seam application on the application server.
Comment 5 Rebecca Newton 2012-05-14 02:35:48 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-JBoss Cache is broken on Enterprise Application Platform 6, which causes JBoss Cache Seam Cache provider to fail in a Seam application on the application server.+JBoss Cache is not supported on Enterprise Application Platform 6, which causes JBoss Cache Seam Cache provider to fail in a Seam application on the application server.
Comment 6 mark yarborough 2012-06-18 11:32:10 EDT
WFK 2.0 does not delivere Seam 2.2, however, these issues have already been documented in the EAP 6 release notes, so no need to duplicate each issue in WFk 2.0 release notes. However, we should include a pointer to the EAP 6 release notes to assist customers looking for Seam 2.2 bug information.
Comment 7 JBoss JIRA Server 2012-07-17 15:11:13 EDT
Marek Novotny <mnovotny@redhat.com> updated the status of jira JBPAPP-8850 to Closed
Comment 8 JBoss JIRA Server 2012-07-17 15:11:13 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBPAPP-8850

Infinispan is not supported on EAP5

Note You need to log in before you can comment on or make changes to this bug.