Bug 817061 - lyx crashes every time upon loading any document or after first character into a new one
lyx crashes every time upon loading any document or after first character int...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 10:44 EDT by John Florian
Modified: 2012-07-26 10:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 10:38:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strash of crash using Method A (711.57 KB, application/octet-stream)
2012-04-27 10:45 EDT, John Florian
no flags Details
strash of crash using Method B (971.21 KB, application/octet-stream)
2012-04-27 10:47 EDT, John Florian
no flags Details

  None (edit)
Description John Florian 2012-04-27 10:44:38 EDT
Description of problem:
I can no longer open any of my existing Lyx docs nor enter any text into a new one.  Lyx will launch correctly if it is started without specifying a document name.  Upon trying to load a document it will crash.  Upon trying to enter the first character in a new document it will crash.

Version-Release number of selected component (if applicable):
lyx-2.0.3-1.fc16.x86_64

How reproducible:
always

Steps to Reproduce:

Method A
1. Start Lyx.
2. Open an existing lyx document.
3. Crash

or

Method B
1. Start Lyx.
2. File / New
3. Enter a few characters of text.
4. Crash
Comment 1 John Florian 2012-04-27 10:45:28 EDT
Created attachment 580784 [details]
strash of crash using Method A
Comment 2 John Florian 2012-04-27 10:47:09 EDT
Created attachment 580785 [details]
strash of crash using Method B
Comment 3 John Florian 2012-04-27 10:47:54 EDT
Umm, those attachments are "strace" not "strash".
Comment 4 Rex Dieter 2012-04-27 12:18:09 EDT
A backtrace would likely be more helpful, if possible.
Comment 5 José Matos 2012-04-27 13:58:23 EDT
I agree with Rex. A backtrace would be nice to understand what is going on.

FWIW I can not reproduce any of this on either f16 or f17.
Comment 6 John Florian 2012-04-27 16:06:11 EDT
How can I get one of those?  (abrt doesn't seem to let me ... I'm assuming because of the dire warning that my kernel is tainted due to the necessary use of the dreaded nvidia drivers.)
Comment 7 José Matos 2012-04-28 13:29:18 EDT
See http://fedoraproject.org/wiki/StackTraces

One option is to install the the debug rpms

# debuginfo-install lyx

and then to run lyx from gdb

$ gdb lyx
> run
Comment 8 John Florian 2012-05-07 14:26:21 EDT
I'm having no luck capturing a backtrace:

$ gdb lyx
GNU gdb (GDB) Fedora (7.3.50.20110722-13.fc16)
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/lyx...Reading symbols from /usr/lib/debug/usr/bin/lyx.debug...done.
done.
(gdb) run
Starting program: /usr/bin/lyx 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
warning: "/usr/lib/debug/usr/lib64/libicudata.so.46.0.debug": separate debug info file has no debug info
Detaching after fork from child process 8033.

Program terminated with signal SIGKILL, Killed.
The program no longer exists.
(gdb) thread apply all bt full
(gdb) bt
No stack.
(gdb)


I couldn't get a core dump either.  I did learn that if I run lyx as root (or some other user) it works fine and that there's something troubling in my ~/.lyx/ apparently.  Any best guesses or easy ways of getting to the bottom of it or do I need to just roll up my sleeves and start bisecting it?  I really don't even know if there's much of value to me.
Comment 9 José Matos 2012-07-26 03:24:25 EDT
Does this problems still continues with the latest version (2.0.4)?

One possible option if the problem persists is to rename the $HOME/.lyx directory to something else and then we can see if a fresh directory still causes problems since this just happens for one user.
Comment 10 John Florian 2012-07-26 10:34:59 EDT
(In reply to comment #9)

> One possible option if the problem persists is to rename the $HOME/.lyx
> directory to something else and then we can see if a fresh directory still
> causes problems since this just happens for one user.

That's exactly the approach I took, prior to the release of 2.0.4, as I was somewhat desperate of regaining my beloved LyX to continue work.  I did have my original still laying around so I reinstituted that just now to see what would happen under 2.0.4 and found no problem with one sample document that I know was giving me problems earlier -- any document, including brand new ones was sufficient to bomb the prior version.  This particular document has evolved much since my original woes, but nonentheless I'm feel confident in saying that 2.0.4 did resolve something related to the handling of my original ~/.lyx.

Now I just need to decide which to keep -- I think I'll stick with the original for now, if for no reason other than it probably still has a more complete personal spelling dictionary.

It's okay by me to close this ticket, if you feel that's appropriate and no further investigation is needed.
Comment 11 Rex Dieter 2012-07-26 10:38:10 EDT
ok, thanks.

Note You need to log in before you can comment on or make changes to this bug.