Bug 817062 - p2v-server debugging accidentally hardcoded on
Summary: p2v-server debugging accidentally hardcoded on
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-27 14:44 UTC by Matthew Booth
Modified: 2012-06-20 12:42 UTC (History)
7 users (show)

Fixed In Version: virt-v2v-0.8.7-6.el6
Doc Type: Bug Fix
Doc Text:
No documentation required. This bug was never in a RHEL release.
Clone Of:
Environment:
Last Closed: 2012-06-20 12:42:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0788 0 normal SHIPPED_LIVE virt-v2v bug fix and enhancement update 2012-06-19 20:34:39 UTC

Description Matthew Booth 2012-04-27 14:44:55 UTC
Description of problem:
A previous commit accidentally hardcoded DEBUG logging on in virt-p2v-server, which is part of the virt-v2v package. It must be disabled.

This is fixed upstream in commit 630e0711ae3d9e4b5918603b3778ed3af703b6c2.

Version-Release number of selected component (if applicable):
virt-v2v-0.8.7-5.el6

Comment 2 Matthew Booth 2012-05-02 14:08:10 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation required.

This bug was never in a RHEL release.

Comment 4 Cui Lei 2012-05-04 02:07:12 UTC
This bug have been reproduced in virt-v2v-0.8.7-5.el6 build and verified fixed in virt-v2v-0.8.7-6.el6 build.
Here is the detail,
relevant code in virt-v2v-0.8.7-5.el6:

# Initialize logging
logmsg_init('syslog');
logmsg_level(DEBUG);

# Uncomment these 2 lines to capture debug information from the conversion
# process
$ENV{'LIBGUESTFS_DEBUG'} = 1;
$ENV{'LIBGUESTFS_TRACE'} = 1;


Current code in virt-v2v-0.8.7-6.el6:

# Initialize logging
logmsg_init('syslog');
#logmsg_level(DEBUG);

# Uncomment these 2 lines to capture debug information from the conversion
# process
#$ENV{'LIBGUESTFS_DEBUG'} = 1;
#$ENV{'LIBGUESTFS_TRACE'} = 1;

Debugging feature in virt-p2v-server have been disabled.

Comment 6 errata-xmlrpc 2012-06-20 12:42:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0788.html


Note You need to log in before you can comment on or make changes to this bug.