Bug 817071 - ipa-server-install ignores --hostname
ipa-server-install ignores --hostname
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 11:10 EDT by David Kovalsky
Modified: 2015-01-16 03:42 EST (History)
5 users (show)

See Also:
Fixed In Version: ipa-3.2.1-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:41:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2012-04-27 11:10:40 EDT
ipa-sever-install has optinal parameters, which have all the behavior that if I specify a value on the command line I'm not asked interactively for the install. 

This is not true for --hostname. 

Reproducer:

# ipa-server-install --hostname foo.bar --no-host-dns --domain bar

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
<snip />


To accept the default shown in brackets, press the Enter key.

Enter the fully qualified domain name of the computer
on which you're setting up server software. Using the form
<hostname>.<domainname>
Example: master.example.com.


Server host name [foo.bar]: 

###### dkovalsk: I'm actually asked for the hostname, even if I specify the correct FQDN

Warning: skipping DNS resolution of host foo.bar

Warning: hostname foo.bar does not match system hostname ###REAL_DOMAIN_CUT###

System hostname will be updated during the installation process
to prevent service failures.


#### dkovalsk: domain is properly skipped because it's specified on the command line

Unable to resolve IP address for host name
Please provide the IP address to be used for this host name:


### (and so forth)
ipa-server-2.1.3-9.el6.x86_64
ipa-server-2.2.0-11.el6.x86_64
Comment 2 Martin Kosek 2012-04-30 04:23:21 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2692
Comment 10 Namita Soman 2013-12-16 09:22:10 EST
Verified using ipa-server-3.3.3-5.el7.x86_64

Automated test result:
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: BZ817071 -  ipa-server-install ignores --hostname
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::


MARK-LWD-LOOP -- 2013-12-03 16:09:45 --
:: [   PASS   ] :: Running '/usr/bin/expect /tmp/remote_exec.exp >> /tmp/remote_exec.out 2>&1' (Expected 0, got 0)
set timeout 360 
set send_slow {1 .1}
spawn ipa-server-install --setup-dns --forwarder=10.10.160.1 --hostname=qeblade6.testrelm.com -r TESTRELM.COM -n testrelm.com -p Secret123 -P Secret123 -a Secret123
match_max 100000
sleep 2
expect "Existing BIND configuration detected*"
send "yes"
send "\r"
expect "Do you want to configure the reverse zone*"
send "no"
send "\r"
expect "Continue to configure the system with these values*"
send "yes"
send "\r"
expect eof 
:: [   PASS   ] :: Running 'cat /tmp/remote_exec.exp' (Expected 0, got 0)
spawn ipa-server-install --setup-dns --forwarder=10.10.160.1 --hostname=qeblade6.testrelm.com -r TESTRELM.COM -n testrelm.com -p Secret123 -P Secret123 -a Secret123

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
  * Configure a stand-alone CA (dogtag) for certificate management
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure DNS (bind)

To accept the default shown in brackets, press the Enter key.

WARNING: conflicting time&date synchronization service 'chronyd' will be disabled
in favor of ntpd

Existing BIND configuration detected, overwrite? [no]: yes
Warning: skipping DNS resolution of host qeblade6.testrelm.com
Do you want to configure the reverse zone? [yes]: no

The IPA Master Server will be configured with:
Hostname:      qeblade6.testrelm.com
IP address:    10.16.4.29
Domain name:   testrelm.com
Realm name:    TESTRELM.COM

BIND DNS server will be configured to serve IPA domain with:
Forwarders:    10.10.160.1
Reverse zone:  No reverse zone

Continue to configure the system with these values? [no]: yes

The following operations may take some minutes to complete.
Please wait until the prompt is returned.

Configuring NTP daemon (ntpd)
<..snip..>
:: [   PASS   ] :: Running 'cat /tmp/remote_exec.out' (Expected 0, got 0)
:: [ 16:12:43 ] ::  Verify kinit
:: [ 16:12:43 ] ::  execute expect file: /tmp/kinit.6698.exp

set timeout 30
set force_conservative 0
set send_slow {1 .001}
spawn /usr/bin/kinit -V admin
expect Password for *
send -s -- Secret123\r
expect eof 
spawn /usr/bin/kinit -V admin
SecrUsing existing cache: persistent:0:krb_ccache_N2bBK6M
Using principal: admin@TESTRELM.COM
et123
Password for admin@TESTRELM.COM: 
Authenticated to Kerberos v5
Default principal: admin@TESTRELM.COM
:: [ 16:12:44 ] ::  Success: kinit as [admin] with password [Secret123] was successful.
:: [   PASS   ] :: Get administrator credentials after installing (Expected 0, got 0)
:: [ 16:12:44 ] ::  Verify ipactl status
<..snip..>
BZ817071-ipa-server-install-ignores-hostname result: PASS
Comment 12 Ludek Smid 2014-06-13 06:41:51 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.