Bug 817076 - Saving empty process asset causes error after which the process cannot be fixed or deleted
Saving empty process asset causes error after which the process cannot be fix...
Status: CLOSED DUPLICATE of bug 816120
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRM (Guvnor) (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Tihomir Surdilovic
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 11:22 EDT by Jiri Locker
Modified: 2012-04-27 11:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 11:31:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
EmptyProcessException-server.log (23.68 KB, application/octet-stream)
2012-04-27 11:22 EDT, Jiri Locker
no flags Details

  None (edit)
Description Jiri Locker 2012-04-27 11:22:59 EDT
Created attachment 580790 [details]
EmptyProcessException-server.log

Description of problem:
If a new process is created and saved immediately after the asset opens (no changes are made before saving it), an error occurs. After that it is not possible to save the process even if some changes are made and when the asset is closed it is not possible to open it, therefore it cannot be deleted.

(The only way to get rid of such broken process is to archive it before it is closed.)


Version-Release number of selected component (if applicable):
ER6

How reproducible:


Steps to Reproduce:
1. in Guvnor, create a new BPMN2 process
2. save the process immediately after the designer initializes

Actual results:
Error message is displayed, exception is logged.

Expected results:
Saving empty process should not cause error.

Additional info:
Comment 1 Jiri Locker 2012-04-27 11:31:39 EDT

*** This bug has been marked as a duplicate of bug 816120 ***

Note You need to log in before you can comment on or make changes to this bug.