Bug 817110 - CUPS not working with samba4
CUPS not working with samba4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 814793 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 14:14 EDT by Bruno Wolff III
Modified: 2012-08-12 22:25 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-12 22:25:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2012-04-27 14:14:53 EDT
Description of problem:
With the samba4 packages installed instead of the samba packages, cups won't print to a remote printer using smb. I am not sure which samba4 package causes the issue, but since I had switched back and forth a few times lately, I did find that going back to samba made things work again. system-config-printer shows the following error message: "Idle - File "/usr/lib/cups/backend/smb" not available: No such file or directory". I was unable to find an owner for that file, so I suspect things are a bit more complicated than samba4 not providing that file.

Version-Release number of selected component (if applicable):
cups-1.5.2-12.fc17.x86_64
samba4-4.0.0-43alpha18.fc17.x86_64

How reproducible:
Seems to happen reliably

Steps to Reproduce:
1.Replace samba packages with samba4 packages
2.Try to print to network printer using smb
3.
  
Actual results:
Print jobs stay queued

Expected results:
Print jobs print

Additional info:
Comment 1 Alexander Bokovoy 2012-05-09 11:25:14 EDT
This is expected at current stage of the development of samba4 package. Simply do not install samba4 yet.
Comment 2 Andreas Schneider 2012-05-09 11:32:21 EDT
The symlink is created by the cups package during installation. There is a trigger if the samba-client package is installed.

The same trigger needs to be added for samba4-client package.

Reassigning to cups. Thanks!
Comment 3 Andreas Schneider 2012-05-09 11:34:23 EDT
*** Bug 814793 has been marked as a duplicate of this bug. ***
Comment 4 Bruno Wolff III 2012-05-09 14:10:28 EDT
I tested this and was able to print using samba4 instead of samba. I did end up having to reinstall the updated cups after switching to samba4 to get it to work. My guess is that the trigger is sensitive to the order in which the packages are installed. (And that is why there is a comment above saying that samba4-client needs a trigger as well.)
Comment 5 Fedora Update System 2012-05-16 06:15:15 EDT
cups-1.5.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/cups-1.5.3-1.fc17
Comment 6 Fedora Update System 2012-05-29 06:25:09 EDT
Package cups-1.5.3-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-1.5.3-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7958/cups-1.5.3-2.fc17
then log in and leave karma (feedback).
Comment 7 Nadav Har'El 2012-06-24 04:14:58 EDT
I have exactly the same problem on my up-to-date Fedora 17 system: I have samba4 instead of samba (I'm not even sure why, I don't remember making this choice deliberately), and printing to Samba printers simply stopped working, with everything simply remaining on the queue and lpq tells me that my printer "is not ready".

Doing 'yum update --enablerepo=updates-testing cups-1.5.3-2.fc17' as suggested above indeed fixed the problem!

So why, more than a month later, isn't this update moved to the general updates repository?
Comment 8 Alexander Bokovoy 2012-06-24 04:58:03 EDT
Look at the link in comment 6. This package has negative karma due to other regressions and thus is kept out of stable updates.
Comment 9 Fedora Update System 2012-07-26 18:37:54 EDT
Package cups-1.5.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-1.5.4-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7958/cups-1.5.4-1.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-08-12 22:25:25 EDT
cups-1.5.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.