Bug 817136 - vmstat fails intermittently with "floating point exception"
vmstat fails intermittently with "floating point exception"
Status: CLOSED DUPLICATE of bug 820507
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: procps (Show other bugs)
6.3
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jaromír Cápík
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 15:26 EDT by Kim van der Riet
Modified: 2016-01-31 20:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-12 10:44:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim van der Riet 2012-04-27 15:26:16 EDT
Description of problem:

vmstat 5 fails intermittently with "floating point exception"

[kpvdr@mrg42 ~]$ vmstat 5
procs -----------memory---------- ---swap-- -----io---- --system-- -----cpu-----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
 0  0      0 12041096 148456 3566076    0    0    14   170  174   53  8  1 90  0  0	
Floating point exception
[kpvdr@mrg42 ~]$ vmstat 5
procs -----------memory---------- ---swap-- -----io---- --system-- -----cpu-----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
 0  0      0 12037796 148628 3566112    0    0    21   257  264   81 12  2 86  1  0	
Floating point exception

Sometimes, it will run for some time before failure, but seems most likely to fail when the machine is idle. I have never seen a failure under load. I use 5 sec intervals for my measurements, other values may fail also, but I have neither tested nor observed any failures other than with the value of 5.

Version-Release number of selected component (if applicable):

RHEL6.3-20120427.n.0_nfs-Server-x86_64 installed on HP blade (BL460c G5)

How reproducible:

Variable. Sometimes it will fail several times in a row, other times I can run for an hour before seeing a failure.

Steps to Reproduce:
1. Machine is idle
2. run "vmstat 5"
3. If there is no immediate failure, cycle a load on the box with periods of no activity.
  
Actual results:

vmstat stops with "Floating point exception"

Expected results:

vmstat continues running

Additional info:

Box exhibiting failure: mrg42.
Contact me for access if required.
Comment 4 Suzanne Yeghiayan 2012-05-01 11:16:35 EDT
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 5 Jaromír Cápík 2012-06-12 10:44:35 EDT
Hello Kim.

This is very probably a duplicate of Bug 819073, Bug 820507 and Bug 696202.
I'm closing this one.

If you believe it isn't a duplicate, then don't hesitate to reopen.

Thank you.

Regards,
Jaromir.

*** This bug has been marked as a duplicate of bug 820507 ***

Note You need to log in before you can comment on or make changes to this bug.