Bug 81715 - hwbrowser displays incorrect or incomplete information.
hwbrowser displays incorrect or incomplete information.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-13 02:48 EST by Elton Woo
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:29:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elton Woo 2003-01-13 02:48:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
running the hwbrowser correctly identifies both my CD drives (DVD and CDRW)
by Manufacturer, driver, and availabilty. Ditto for my network card. OTH, the rest 
of my hardware is only partially identified, even though the same info correctly
displays in KDE's Control Center.

(*Except* for sound, which KDE reports "no information available*!!)

Please see in Additional Information what and how information on my hardware is
displayed. IMHO, this is self-evident where there are inconsistencies or errors.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run hwbrowser
2.
3.
    

Actual Results:  Displays only _partially correct_ information on my system's
hardware

Expected Results:  Should correctly identify Manufacturer, device, and that
device is active 
(*not* "N/A")

Additional info:

HW Browser shows:

Floppy Disks
3.5" 1.44MB floppy drive
Manufacturer: Unknown Driver:unknown  Device:/dev/fd0
REM: There is no floppy drive connected to the motherboard.

LS-120 Vers. 5.00 UHD Floppy [Matsushita superdisk drive]
Manufacturer: Unknown Driver: none or built-in Device:/dev/hdb  
REM:This device is mounted (before invoking hwbrowser)

Pointing devices: 
Logitech Inc. Optical Wheel mouse 
Manufacturer:Unknown ?? Driver: mousedev Device: N/A  ??
REM:[connected to Atmel hub]
 
Printers: 
Lexmark Lexmark Z53 
Manufacturer: Unknown ?? Driver: unknown Device: N/A   ??
REM:[connected to Atmel hub]

Sound cards:
ES1371 [AudioPCI-97] 
Manufacturer: Ensoniq Driver: es 1371 Device: N/A ??

System devices:

Atmel Corp. 4-port hub Manufacturer: Unknown ?? Driver: unknown  Device: N/A ??
Logitech Inc. Wingman RumblePad Manufacturer: Unknown ??  Driver: unknown
Device: N/A ??
Seiko Epson Corp. Perfection 610 Manufacturer:Unknown ??  Driver: unknown
Device: N/A
USB UHCI Root Hub Manufacturer: Unknown  Driver: unknown Device: N/A
USB UHCI Root Hub Manufacturer: Unknown  Driver: unknown Device: N/A
VT82C686 [Apollo Super South]Manufacturer: VIA Technologies  Driver: parport_pc
Device: N/A

USB Devices: [REM: see USB UHCI devices above!!]
USB Manufacturer:VIA Technologies Driver: usb-uhci  Device: N/A
USB Manufacturer:VIA Technologies Driver: usb-uhci  Device: N/A

Video cards: 
RIVA TNT2 Model 64 Manufacturer: nVidia Corporation  Driver: Card: RIVA TNT2
Device: N/A ??
Comment 1 Brent Fox 2003-02-06 20:22:50 EST
Ok, there are a number of issues in this report, but I'll try to sort it out.

The hardware info in hwbrowser is provided by kudzu, so some of these issues may
actually be kudzu bugs instead of hwbrowser.  

1) Kudzu reports a floppy drive even though there isn't one.  I've filed this as
bug #83682.

2) hwbrowser was not showing the Manufacturer for USB devices.  This should be
fixed in hwbrowser-0.8-6.

3) hwbrowser was showing "Device:" as "N/A" for many devices.  I've changed it
so that the Device line only appears if kudzu returns a valid device.  This
should be fixed in hwbrowser-0.8-6

The USB UHCI devices sort of bug me since there's no manufacturer data to show,
but I can't do much about that.  I think that's about all I can reasonably fix
for this release.  QA, please verify.
Comment 2 Brent Fox 2003-05-25 10:29:28 EDT
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.

Note You need to log in before you can comment on or make changes to this bug.