This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 817151 - BCM4331 firmware missing from install DVD
BCM4331 firmware missing from install DVD
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 16:39 EDT by John Reiser
Modified: 2013-07-04 09:02 EDT (History)
5 users (show)

See Also:
Fixed In Version: lorax-17.17-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 00:14:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/tmp/syslog (146.41 KB, text/plain)
2012-04-27 16:39 EDT, John Reiser
no flags Details
lspci; lspci -vvn (36.03 KB, text/plain)
2012-04-27 16:39 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2012-04-27 16:39:26 EDT
Created attachment 580863 [details]
/tmp/syslog

Description of problem: Booting Fedora-17-Final.TC1-x86_64-DVD.iso from DVD on Apple Macintosh Macmini5,1 [the current model] complains of missing firmware.


Version-Release number of selected component (if applicable):
lorax-17.16-1
anaconda-17.23-1

How reproducible: every time


Steps to Reproduce:
1. Boot Fedora-17-Final.TC1-x86_64-DVD.iso from DVD on Apple Macintosh Macmini5,1
2. Switch to VT2 and examine /tmp/syslog
3.
  
Actual results:
ERR kernel:[   37.293616] b43-phy0 ERROR: Firmware file "b43/ucode29_mimo.fw" not found
ERR kernel:[   37.295017] b43-phy0 ERROR: Firmware file "b43-open/ucode29_mimo.fw" not found
ERR kernel:[   37.295021] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.


Expected results: no complaints


Additional info:
Comment 1 John Reiser 2012-04-27 16:39:51 EDT
Created attachment 580864 [details]
lspci; lspci -vvn
Comment 2 Will Woods 2012-05-02 10:34:23 EDT
Is b43/ or b43-open/ present in /lib/firmware or /run/initramfs/lib/firmware?
Comment 3 John Reiser 2012-05-02 12:55:55 EDT
No, neither b43/ nor b43-open/ are present on the installer media.

# mount -o ro,loop Fedora-17-Final.TC2-x86_64-DVD.iso /mnt/tmp1
# cd /mnt/tmp1/images/pxeboot
# xz -d <initrd.img  |  cpio --list  |  grep b43
160297 blocks
#   ### note empty output from grep: no lines containing "b43"


[I used the explicit xz|cpio because the most-handy lsinitrd was from Fedora 14, where lsinitrd does not understand xz.  On a newer system I could have used:
"lsinitrd initrd.img  |  grep b43" ]
Comment 4 Will Woods 2012-05-02 15:03:43 EDT
Ah. b43-openfwwf is the only firmware package that isn't named "*-firmware".

Adding it to the lorax install template should fix this.
Comment 5 Fedora Update System 2012-05-03 14:13:17 EDT
lorax-17.17-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lorax-17.17-1.fc17
Comment 6 Fedora Update System 2012-05-03 23:09:17 EDT
Package lorax-17.17-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-17.17-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7251/lorax-17.17-1.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-05-08 00:14:03 EDT
lorax-17.17-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.