Bug 817154 - Kernel- Check OS kernel build fails with MRG-RT kernel
Kernel- Check OS kernel build fails with MRG-RT kernel
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.5
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Greg Nichols
Guangze Bai
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-04-27 16:52 EDT by Beth Uptagrafft
Modified: 2015-02-08 16:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
redhatrelease.py patch add in check and parsing for mrg release file (6.42 KB, patch)
2012-05-16 09:33 EDT, Greg Nichols
no flags Details | Diff
info test patch to check for RT kernel and MRG release file (3.83 KB, patch)
2012-05-16 09:35 EDT, Greg Nichols
no flags Details | Diff
info test patch on R26 fixing traceback (1.86 KB, patch)
2012-05-18 08:34 EDT, Greg Nichols
no flags Details | Diff
info test patch on R26 fixing traceback (2.04 KB, patch)
2012-05-18 09:47 EDT, Greg Nichols
no flags Details | Diff
kernelInfo (py and xml) patch adding RT product (4.18 KB, patch)
2012-05-18 10:32 EDT, Greg Nichols
no flags Details | Diff
info test patch on R26 fixing traceback, adding RT product info (2.31 KB, patch)
2012-05-18 10:33 EDT, Greg Nichols
no flags Details | Diff
info test patch on R28 fixing typo. (640 bytes, patch)
2012-05-29 09:06 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Beth Uptagrafft 2012-04-27 16:52:47 EDT
v7.noarch 0:1.5-22.el6
https://beaker.engineering.redhat.com/recipes/476252

./v7/realtime Failure
http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2012/04/2238/223873/476252/5502969/29926961/test_log-v7-realtime.log


The 2 RT-specific tests are within the threshold, but the kernel check fails:

Subtest: Kernel - Check OS kernel build, version
+ rpm -ql kernel-rt-3.2.16-rt27.23.el6rt
Error: Kernel is 3.2.16-rt27.23 and not RHEL 6.3 GA (2.6.32-)
Boot Parameters: ro root=/dev/mapper/vg_hpxw660001-lv_root rd_NO_LUKS
LANG=en_US.UTF-8 rd_NO_MD  KEYTABLE=us console=ttyS0,115200
crashkernel=auto rd_LVM_LV=vg_hpxw660001/lv_swap
rd_LVM_LV=vg_hpxw660001/lv_root SYSFONT=latarcyrheb-sun16 rd_NO_DM
ignore_loglevel
FAIL


This needs to be updated to include the MRG-RT kernels.
Comment 12 Greg Nichols 2012-05-16 09:33:50 EDT
Created attachment 584960 [details]
redhatrelease.py patch add in check and parsing for mrg release file
Comment 13 Greg Nichols 2012-05-16 09:35:55 EDT
Created attachment 584961 [details]
info test patch to check for RT kernel and MRG release file
Comment 22 Greg Nichols 2012-05-18 10:32:28 EDT
Created attachment 585428 [details]
kernelInfo (py and xml) patch adding RT product
Comment 23 Greg Nichols 2012-05-18 10:33:38 EDT
Created attachment 585429 [details]
info test patch on R26 fixing traceback, adding RT product info
Comment 26 Greg Nichols 2012-05-29 09:06:25 EDT
Created attachment 587401 [details]
info test patch on R28 fixing typo.
Comment 29 Caspar Zhang 2012-06-04 04:05:41 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 31 errata-xmlrpc 2012-06-05 17:37:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.