Bug 817179 - /sbin/grub2-probe: error: failed to get canonical path of /dev/root.
/sbin/grub2-probe: error: failed to get canonical path of /dev/root.
Status: CLOSED DUPLICATE of bug 737370
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 18:31 EDT by Artem S. Tashkinov
Modified: 2012-04-27 18:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 18:59:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artem S. Tashkinov 2012-04-27 18:31:43 EDT
Description of problem: with a custom kernel (3.3.4) build I'm unable to regenerate grub2.cfg using grub2-mkconfig.


Version-Release number of selected component (if applicable): grub2-1.99-19.fc17


How reproducible: always


Steps to Reproduce:
1. Build a custom kernel without initrd
2. Boot into it
3. Run grub2-mkconfig > /tmp/grub.cfg
  

Actual results: /sbin/grub2-probe: error: failed to get canonical path of /dev/root.


Expected results: grub2-mkconfig generates GRUB2 configuration


Additional info: under a custom kernel `/dev/root` file is missing. However it's also missing when I run Fedora built kernels.
Comment 1 Mads Kiilerich 2012-04-27 18:59:07 EDT

*** This bug has been marked as a duplicate of bug 737370 ***

Note You need to log in before you can comment on or make changes to this bug.