Bug 817186 - systemd incorrectly handles virtual text terminals
systemd incorrectly handles virtual text terminals
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 19:31 EDT by Artem S. Tashkinov
Modified: 2012-08-08 19:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 19:30:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artem S. Tashkinov 2012-04-27 19:31:30 EDT
Description of problem: I have set my X.org to start at vt7, however after playing with init 3, init 5 for a while now I have the three first virtual text consoles dead.

There's nothing running on them, I cannot activate them:

# ps ax | grep tt
12210 tty7     Ss+    0:16 /usr/bin/X -background none :0 vt07 -nolisten tcp
12287 tty4     Ss+    0:00 -bash
12318 tty5     Ss+    0:00 /sbin/agetty tty5 38400
12319 tty6     Ss+    0:00 /sbin/agetty tty6 38400

I can switch to vt1/vt2/vt3 but there's nothing there except a blinking cursor. Pressing any keys doesn't cause any reaction.

I have the following configuration:

* LXDM configured to start X.org at vt7
* NVIDIA binary drivers
* Vesa frame buffer activated via vga=0x346 on a kernel command line
Comment 1 Lennart Poettering 2012-08-08 19:30:21 EDT
We do not support display managers whose primary VT is not VT1. That is by design.

Note You need to log in before you can comment on or make changes to this bug.