Bug 817202 - After Using virt-p2v to convert xen server on MD device,it will kernel panic
Summary: After Using virt-p2v to convert xen server on MD device,it will kernel panic
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-p2v
Version: 6.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-28 02:29 UTC by tingting zheng
Modified: 2015-03-12 17:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-12 17:42:10 UTC


Attachments (Terms of Use)
screenshot of xen server kernel panic (126.58 KB, image/png)
2012-04-28 02:31 UTC, tingting zheng
no flags Details
virt-p2v log file for conversion of xen server (4.05 MB, text/plain)
2012-04-28 03:00 UTC, tingting zheng
no flags Details
the initrd of the kernel it's failing to boot (2.36 MB, application/octet-stream)
2012-05-02 03:14 UTC, tingting zheng
no flags Details

Description tingting zheng 2012-04-28 02:29:44 UTC
Description of Problem:
After Using virt-p2v to convert xen server on MD device,it will kernel panic

Version-Release number of selected component:
virt-v2v-0.8.7-5.el6.x86_64
rubygem-virt-p2v-0.8.6-3.el6

How reproducible:
Always

Step to Reproduce:
1.Download the virt-p2v iso from brewweb.

2.Create MD device /dev/md0 with sda1 and sdb1.

3.Install rhel5 with xen kernel on md0.

4.Use virt-p2v to convert the host installed xen server on md0 to libvirt or RHEV.

5.After conversion,boot the guest,it will kernel panic.

Actual Results:
The guest will kernel panic,details see the screenshot.

Expected Results:
The guest can be boot successfully.

Additional info:
1.There is error messages showed in virt-p2v-server-*.log:
Couldn't guess kernel version
number from path for kernel /boot/xen.gz-2.6.18-303.el5 at
/usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm line 728, <>
line 7.

Comment 1 tingting zheng 2012-04-28 02:31:16 UTC
Created attachment 580913 [details]
screenshot of xen server kernel panic

Comment 3 tingting zheng 2012-04-28 03:00:18 UTC
Created attachment 580914 [details]
virt-p2v log file for conversion of  xen server

Comment 4 Matthew Booth 2012-04-30 11:05:46 UTC
The warning about the Xen kernel is ugly, but it looks like a red herring here as the code just skips on to the next kernel. We probably could do a better job of detecting the version number from a Xen kernel, but as I said elsewhere: V2V of a Xen server makes no sense, so this would be exceptionally low priority!

The real issue here is why the guest doesn't boot. For that we're going to need all the boot messages. I think the best way to capture these will be from a serial console. You can do this by configuring the serial console either before conversion or after, whichever suits you best. However, if you configure it after conversion you'll obviously have to use guestfish as the guest doesn't boot! Also you'll have to convert to a libvirt target not a RHEV target, as RHEV doesn't support serial console.

Once you've done the above, can you also please remove the kernel parameters 'rhgb' and 'quiet' from grub, then capture the boot process using 'virsh console ...'. Could you also please attach the initrd of the kernel it's failing to boot.

If it's easier, you can just do the conversion to libvirt, then send me the login details to examine the non-booting guest.

Comment 5 tingting zheng 2012-05-02 03:12:04 UTC
1.Use p2v to convert the rhel5 on MD device to libvirt,configured rhe serial console.
2.Remove the kernel parameters 'rhgb' and 'quiet' from grub,capture the boot process:
# virsh console md-rhel5-reproduce
Connected to domain md-rhel5-reproduce
Escape character is ^]
Memory for crash kernel (0x0 to 0x0) notwithin permissible range
WARNING calibrate_APIC_clock: the APIC timer calibration may be wrong.
PCI: PIIX3: Enabling Passive Release on 0000:00:01.0
�Red Hat nash version 5.1.19.6 starting
mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mountKernel panic - not syncing: Attempted to kill init!
 failed: No such file or directory

Comment 6 tingting zheng 2012-05-02 03:14:10 UTC
Created attachment 581513 [details]
the initrd of the kernel it's failing to boot

Attached the initrd of the kernel it's failing to boot.

Comment 7 RHEL Product and Program Management 2012-05-05 04:14:19 UTC
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 8 Richard W.M. Jones 2015-03-12 17:42:10 UTC
I'm closing this bug:

 - virt-p2v has been rewritten for RHEL 7.2

 - Unofficial previews of the new version are available:
   http://oirase.annexia.org/virt-p2v/

 - If a similar bug occurs with the new version of virt-p2v,
   please open a new bug against Red Hat Enterprise Linux 7 / libguestfs


Note You need to log in before you can comment on or make changes to this bug.