Bug 817213 - anaconda "clearpart --drives=disk/by-id/dm-uuid-mpath-<WWID>" cannot work
Summary: anaconda "clearpart --drives=disk/by-id/dm-uuid-mpath-<WWID>" cannot work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Installation_Guide
Version: 6.3
Hardware: All
OS: Linux
urgent
medium
Target Milestone: rc
: ---
Assignee: Jack Reed
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks: 782183 840685
TreeView+ depends on / blocked
 
Reported: 2012-04-28 04:06 UTC by Gris Ge
Modified: 2018-11-28 20:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-25 23:39:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gris Ge 2012-04-28 04:06:12 UTC
Description of problem:

Anaconda will complain if using 
"clearpart --drives disk/by-id/dm-uuid-mpath-360a98000572d574a4e6f63706772594b --all --initlabel"

====
Specified nonexistent disk disk/by-id/dm-uuid-mpath-360a98000572d574a4e6f63706772594b in clearpart command
====


I also tried this line but failed with same error.
====
clearpart --drives /dev/disk/by-id/dm-uuid-mpath-<WWID> --all --initlabel
====


Version-Release number of selected component (if applicable):

Both RHEL6.3-20120426.2 and RHEL6.2 GA are same error.

How reproducible:
100%

Steps to Reproduce:
1. Use "clearpart --drives disk/by-id/dm-uuid-mpath-<WWID> --all --initlabel"
   to install OS.
2.
3.
  
Actual results:
installation failed.

Expected results:
installation pass.

Additional info:

It might be hard for me to get anaconda log for you as "ondisk" option of beaker cannot work with "manual" option.
Let me know if you can only draft out patch with logs.

Comment 2 RHEL Program Management 2012-05-03 05:41:48 UTC
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 3 Chris Lumens 2012-05-03 18:25:59 UTC
Do those files even exist in /dev/?  Also, can you somehow grab /tmp/storage.log?

Comment 4 Gris Ge 2012-05-04 02:56:03 UTC
Chris,

Yes. That file exist in /dev/ folder and it's recommended way for mpath devices in docs.redhat.com.

I removed the console option and get into shell via ALT+F2.

mpath is not assemble yet when anaconda panic.


/dev/disk/by-id/scsi-360a98000572d574a4e6f63706772594b 

fix this problem.

So this bug goes to two directions:

1. Please confirm whether /dev/disk/by-id/scsi-<WWID> works for all kickstart option, if so, update documents and request use stick on this.

2. Start multipath before any storage checking and make sure both dm-uuid-mpath and scsi works well.

Which one is acceptable for you?

Comment 6 RHEL Program Management 2012-07-16 22:49:01 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 7 Jack Reed 2012-08-08 00:24:10 UTC
Hi Chris,

This bug will necessitate updates to the Installation Guide, and each of the solutions proposed in Comment 4 will have a different impact. Have you determined which approach you will take?

If the first is taken, I'll state that the /dev/disk/by-id/scsi-<WWID> format works for both LVM and non-LVM multipath devices.

If the second, I'll remove the following: "Multipath devices that use LVM are not assembled until after anaconda has parsed the kickstart file. Therefore, you cannot specify these devices in the format dm-uuid-mpath."

Regardless, is the path /disk/by-id/scsi|dm-uuid-mpath-<WWID> erroneous anyway? Should it not be /dev/disk/by-id/scsi|dm-uuid-mpath-<WWID> ?

[See 'clearpart' at http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Installation_Guide/s1-kickstart2-options.html]

Is all this correct?

Comment 8 Chris Lumens 2012-10-17 03:16:49 UTC
Jack - for specifying disks in kickstart commands, either the shorter form of "disk/by-id/XXXX" or the longer form of "/dev/disk/by-id/XXXX" ought to work.  I've not tested whether or not "/disk/..." would work correctly.

For this bug, I am really hesitant to do anything involving starting multipath in a different place for kickstart.  That tends to have some pretty unforseen consequences. Personally, I think we should just modify the documentation to state that the /dev/disk/by-id/scsi-<WWID> format is preferable at least when multipath is involved.

Comment 9 David Cantrell 2012-10-18 14:30:28 UTC
Reassigning to doc-Installation_Guide based on comment #8.  The documentation needs to be updated to indicate the preferred way to specify devices in kickstart files.

Comment 13 Jack Reed 2013-02-25 23:39:56 UTC
This bug has been verified and implemented for 6.4, so I am changing the status to CLOSED CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.