Bug 817250 - [KVM] can't install or boot up 32bit Win8(Beta) guest
[KVM] can't install or boot up 32bit Win8(Beta) guest
Status: CLOSED DUPLICATE of bug 832301
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
x86_64 Linux
unspecified Severity unspecified
: beta
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-28 05:48 EDT by Yongjie Ren
Modified: 2013-01-09 19:55 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 02:52:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yongjie Ren 2012-04-28 05:48:17 EDT
Description of problem:
In RHEL6.3, it can't install or boot up 32bit Win8(beta) guest. The guest will crash with the following error, while 64bit Win8 and 32bit Win7 guest work fine. And, 32bit Win8 guest works fine in RHEL6.2 GA.
-----Win8 Error-------
Your computer needs to restart.
Please hold down the power button.
Error code: 0x0000005D
Parameters:
0x03060D03
0x756E6547
0x49656E69
0x6C65746E
-----Win8 Error-------

BTW, you can get 32bit Win8 ISO from the following website. 
http://windows.microsoft.com/en-US/windows-8/iso

Version-Release number of selected component (if applicable):
RHEL6.3 virtualization RPM packages:
qemu-kvm-0.12.1.2-2.272.el6.x86_64
kernel-2.6.32-262.el6.x86_64
libvirt-0.9.10-11.el6.x86_64
virt-manager-0.9.0-11.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.get 32bit Win8 ISO
2.try to install 32bit Win8 guest in virt-manager
3.(if you already have a 32bit Win8 image, try to boot it up.)
  
Actual results:
32bit Win8 guest crash

Expected results:
install and boot up correctly

Additional info:
Comment 2 Dor Laor 2012-04-30 17:27:24 EDT
Since win8 is not yet a fully supported release I'm moving the bug into the next minor release. We'll look into it anyway to look for the hypervisor issue.
Comment 3 Gleb Natapov 2012-05-03 03:51:18 EDT
0x0000005D is "unsupported processor" error code. What exact command line virt-manager is using to start the VM?
Comment 4 Yongjie Ren 2012-05-07 07:44:32 EDT
(In reply to comment #3)
> 0x0000005D is "unsupported processor" error code. What exact command line
> virt-manager is using to start the VM?
Yeah, it means "unsupported processor".
We can reproduce it in a very simple qemu-kvm command line as following.
/usr/libexec/qemu-kvm -m 1024 -hda win8_32.img

The same command line can start the 32bit Win8 guest in RHEL6.2 GA.
Comment 5 Yan Vugenfirer 2012-06-05 07:25:10 EDT
Will be fixed when the decision to support Windows 8 will be taken.
Comment 6 Ademar Reis 2012-06-18 17:17:51 EDT
*** Bug 832301 has been marked as a duplicate of this bug. ***
Comment 7 Mike Cao 2012-06-18 22:26:57 EDT
Now windows 8 RP(Release Preview) version is born out ,and HCK has already provide the system test and driver test for win8 .

I suggest to to fix this bug in rhel6.4 .Correct me if I were wrong 

Thanks,
Mike
Comment 8 Ademar Reis 2012-06-19 10:32:56 EDT
(In reply to comment #7)
> Now windows 8 RP(Release Preview) version is born out ,and HCK has already
> provide the system test and driver test for win8 .
> 
> I suggest to to fix this bug in rhel6.4 .Correct me if I were wrong 
> 

Agree, win8 install should be part of the acceptance criteria of RHEL6.4.
Comment 10 Dor Laor 2012-08-01 02:52:12 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > 0x0000005D is "unsupported processor" error code. What exact command line
> > virt-manager is using to start the VM?
> Yeah, it means "unsupported processor".
> We can reproduce it in a very simple qemu-kvm command line as following.
> /usr/libexec/qemu-kvm -m 1024 -hda win8_32.img
> 
> The same command line can start the 32bit Win8 guest in RHEL6.2 GA.

As Gleb said, without specifying a virtual cpu model you're using qemu's default which is just a fake cpu. Please use one of the supported virtual model for Intel or AMD (you can query qemu top the supported list by running qemu -cpu ?).

I'll close the bug as we do have reports it works.
Comment 11 Yongjie Ren 2012-08-01 03:02:12 EDT
OK. Please have a look at the following bug (about the same issue).
https://bugs.launchpad.net/qemu/+bug/1007269

Some CPU models(e.g. Qemu32, Core2duo) can work for 32bit Win8. Some(e.g. qemu64) can't work.
Comment 12 Dor Laor 2012-08-01 03:08:32 EDT
(In reply to comment #11)
> OK. Please have a look at the following bug (about the same issue).
> https://bugs.launchpad.net/qemu/+bug/1007269
> 
> Some CPU models(e.g. Qemu32, Core2duo) can work for 32bit Win8. Some(e.g.
> qemu64) can't work.

qemu32 and qemu64 are not the right models, but we have another report from QA and I'll check them up and may re-open the bug. Thanks for the response.
Comment 13 Suqin Huang 2012-08-01 04:13:07 EDT
re-open bug 832301 to trace this issue.
Comment 14 Mike Cao 2012-08-01 05:44:07 EDT
Actually Bug 832301 and this one are the same bugs . I tried all the supported cpu type ,none of them works ,Since Bug 832301 was been reopened ,let's use that one to track this bug .

*** This bug has been marked as a duplicate of bug 832301 ***

Note You need to log in before you can comment on or make changes to this bug.