Bug 817258 - submit results to catalog with filename missing ".gz"
Summary: submit results to catalog with filename missing ".gz"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Retired
Component: Test Suite (harness)
Version: 1.5
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Guangze Bai
URL:
Whiteboard:
Depends On:
Blocks: 767775
TreeView+ depends on / blocked
 
Reported: 2012-04-28 11:14 UTC by Guangze Bai
Modified: 2015-02-08 21:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Clone Of:
Environment:
Last Closed: 2012-06-05 21:37:47 UTC


Attachments (Terms of Use)
catalog.py patch adding ".gz" to the "filename" param on submit (595 bytes, patch)
2012-04-30 17:51 UTC, Greg Nichols
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0711 0 normal SHIPPED_LIVE v7 bug fix and enhancement update 2012-06-06 01:26:37 UTC

Description Guangze Bai 2012-04-28 11:14:14 UTC
Description of problem:

When running v7 submit to send the results to catalog, catalog got the gzipped results xml, but the xmlrpc parameter 'filename' does not contain .gz suffix.

e.g. in this cert
http://hwcert-web2-test.devel.redhat.com/show.cgi?id=731356
you can observe this line:
v7-results-wlan-5-101.nay.redhat.com-20120428110451.xml (id=518806)
Wei Shen thought it should be:
v7-results-wlan-5-101.nay.redhat.com-20120428110451.xml.gz (id=518806)
and he said the file name accuracy is crucial to catalog function. So open this bug.

Version-Release number of selected component (if applicable):
v7-1.5-21

How reproducible:
always

Steps to Reproduce:
1. v7 plan
2. v7 run -t info
3. v7 submit and open the cert url to see this wrong results file name

Comment 1 Greg Nichols 2012-04-30 17:51:03 UTC
Created attachment 581237 [details]
catalog.py patch adding ".gz" to the "filename" param on submit

Comment 5 Caspar Zhang 2012-06-04 08:05:59 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.

Comment 7 errata-xmlrpc 2012-06-05 21:37:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html


Note You need to log in before you can comment on or make changes to this bug.