Bug 817266 - [abrt] iok-2.1.0-2.fc16: magazine_chain_pop_head: Process /usr/bin/iok was killed by signal 11 (SIGSEGV)
[abrt] iok-2.1.0-2.fc16: magazine_chain_pop_head: Process /usr/bin/iok was ki...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: iok (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
abrt_hash:aa325a35d73caffac895219b0bc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-28 09:11 EDT by das
Modified: 2012-06-28 06:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-28 06:23:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (4.89 KB, text/plain)
2012-04-28 09:11 EDT, das
no flags Details
File: maps (13.22 KB, text/plain)
2012-04-28 09:11 EDT, das
no flags Details
File: backtrace (39.41 KB, text/plain)
2012-04-28 09:11 EDT, das
no flags Details

  None (edit)
Description das 2012-04-28 09:11:08 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        iok
crash_function: magazine_chain_pop_head
executable:     /usr/bin/iok
kernel:         3.3.2-6.fc16.i686
pid:            4057
pwd:            /home/dd
reason:         Process /usr/bin/iok was killed by signal 11 (SIGSEGV)
time:           Sat 28 Apr 2012 05:45:29 PM IST
uid:            1000
username:       dd

backtrace:      Text file, 40357 bytes
dso_list:       Text file, 5006 bytes
maps:           Text file, 13541 bytes

build_ids:
:4b65b2ab36082e9552ad2014fac436421c4f65ad
:e86c829bf8553d6b593dbd8c4df0957268dc8328
:11154ce3289d599ddf0cb7aec347964357ecde6f
:b51d82e58cf1d3dab20e44b114cfcf7ee1f31c74
:96b666a7f6d7a80ea6f9aef54f0cdd0f6190c058
:647951954dab9eadcf521b97c5f9d7566b1e79c8
:a031ec247ebfa2c35d637f0c427474d7a0e43904
:7ebe92fe862ff1ced28ef663113303af0fcdd9e3
:92418f7b783e29ab8440148e3fb0cbcfb8bb354a
:1002abe0291e2b40a073f1d82ed0322e82a760dc
:3aed71a6e79a28101ca36e6e9b3e8e053b73421a
:b2d5c5f02b6e6eb34dc593699c0b0bf516280159
:a0b366e13cecd6a811ac0afa3481d443b583aa4c
:42859023e4ec83a16446984b1e0c7510a38731c4
:57199fcccbf44c6d5b9d3f38d3f9943cf2d73381
:fb5857630898b86982a33a2148c700026700dd01
:373fb51a03d9b1c9e1c2ba80db764817cf843d77
:66bde8f1c5ea0505d428ab205352524e2ccfa7ac
:798697a352bae4178953ba502fb04f33dd0ed987
:ddd5fbd9c73dba64e1130590cfc1fb32e31d85ea
:b15b3676f0d78173fc1a46eb9e7e32f4b3cca6bb
:d2fa47ac2ef035e4573199292f6d6352a0132124
:b13cac156e2f55d436d38abd7d82c6f0b2537dd1
:eb703ad658873568367d1ac793f0f45c0a34b82c
:7b428cc791b4c5e1d6dbe1d1c0997a8485c3d7db
:2db77e82f9cf6054c8c51f0e059ff75075dbbc36
:5bfb5514afe40f504eaee43c6b73147644483503
:0351a659bc0812678c67f62af1f802a5f367befc
:28b8cc9cda751c67558ec59cc16019154ebf56ae
:20e55e40b2f98606fcb0891424b09eb7e723ce8f
:4a19f266c74dade2555f5e1aefa43d509ccff81e
:5b853064c3d832d471e71bb67b714a7f69ff11d3
:15bab279752ad8e30f901abae77bcb1ed1f38977
:6400f8b1506a2b01270ddb7fa0d07487fc7dbaa6
:1ecbaf5c5ac1f22012c83df335687b3c09ae5289
:23d1086014ed5544b3df4cee1f95694032252322
:c220d34a217c715968cf4eec464fe5301122c592
:e012145a98558b7d015f3ccf3cacfac44b498980
:ced82078ed2f1dd18f92fb24bf6b760a4f5b178c
:faa844e460702359079f4f15f1f881e87777abb6
:5031c4c03882fc3c5cc3dd84e2b4491d8bd08af3
:4cadcee4cbcd48d8b8766361bf2e80d593a46536
:bdbcb7ad0ae16806e9002af3c6d1ec65353108a0
:8a257536ca5f5aee876e236d9bab65868b0b385f
:82348106e4283b6a42803315774717d3acfc11b4
:8403f33f0be1a3653acd05b560f87aa1363d02d7
:82674b49345364df4c158e8258b93fd4d8fdbae0
:1c92bde3bc752e5630e24d8699a50bcff735af0b
:e42d500dc9e803be62453540b4c81a12e96a006a
:d94f52f020f5a21d89ce70745a9bfb78cee38ba4
:70ec0be07448920a83c0bceafed09d46008e56b1
:55433495aa80cf9e1f994ea7e7ae278422ef1ede
:53a185b58e6bee5f10174dbe94d71180903dfc89
:83828a31823ccb1a2e2f04736f01f6c41ba1e360
:a96b0d7bb580197b7e7f186f831df6cdc2d6a9e2
:1e433d5156c8decab4ff0f1125eefb5a5bef4622
:4b045111479e1ec97d0ef5668482bf808e8dadba
:10cec21724c13b95ec03f00985b0405412817a49

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:SSH_AGENT_PID=1334
:HOSTNAME=mamdo.ddnet
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/home/dd/.gnupg/S.gpg-agent:1356:1
:GLADE_PIXMAP_PATH=:
:XDG_MENU_PREFIX=xfce-
:TERM=dumb
:SHELL=/bin/bash
:HISTSIZE=1000
:XDG_SESSION_COOKIE=5d97b49b3447667d63926c6500000007-1335584380.890153-1825391648
:GNOME_KEYRING_CONTROL=/tmp/keyring-X0Bsy0
:IMSETTINGS_MODULE=IBus
:USER=dd
:GLADE_MODULE_PATH=:
:SSH_AUTH_SOCK=/tmp/ssh-KQtQmjdF1249/agent.1249
:USERNAME=dd
:XDG_CONFIG_DIRS=/etc/xdg
:MAIL=/var/spool/mail/dd
:DESKTOP_SESSION=xfce
:PATH=/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/dd/bin
:QT_IM_MODULE=xim
:PWD=/home/dd
:XMODIFIERS=@im=ibus
:KDE_IS_PRELINKED=1
:LANG=en
:US.UTF-8
:GNOME_KEYRING_PID=1243
:KDEDIRS=/usr
:GDMSESSION=xfce
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:SHLVL=2
:XDG_SEAT=seat0
:HOME=/home/dd
:LOGNAME=dd
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-QOVepusnOv,guid=b4088ebe9a9fd4a6e5c3a4a000000022
:XDG_DATA_DIRS=/usr/local/share:/usr/share
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/dd
:GLADE_CATALOG_PATH=:
:LIBGLADE_MODULE_PATH=:
:GTK_IM_MODULE=ibus
:CCACHE_HASHDIR=
:XAUTHORITY=/var/run/gdm/auth-for-dd-bNg2AN/database
:_=/usr/bin/xfce4-session
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1365,unix/unix:/tmp/.ICE-unix/1365
:DISPLAY=:0.0
:DESKTOP_STARTUP_ID=xfce4-panel/iok/1372-5-mamdo.ddnet_TIME30982629

smolt_data:
:
:
:General
:=================================
:UUID: 0ffffaad-2f47-4a30-91a5-5372d96cb139
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 6019.69
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2997
:System Memory: 3529
:System Swap: 2047
:Vendor: System manufacturer
:System: System Product Name System Version
:Form factor: Desktop
:Kernel: 3.3.2-6.fc16.i686
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10168:4163:33145) pci, None, PCI/ISA, P5KPL-VM Motherboard
:(32902:10690:4163:33456) pci, i915, VIDEO, P5KPL-VM Motherboard
:(32902:10176:4163:33145) pci, ata_piix, STORAGE, P5KPL-VM Motherboard
:(32902:10192:4163:33145) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:4163:33145) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(32902:10200:4163:33424) pci, snd_hda_intel, MULTIMEDIA, P5KPL-VM Motherboard
:(32902:10207:4163:33145) pci, ata_piix, STORAGE, P5KPL-VM Motherboard
:(32902:10202:4163:33145) pci, i801_smbus, SERIAL, P5KPL-VM Motherboard
:(32902:9294:4163:33145) pci, None, PCI/PCI, 82801 PCI Bridge
:(4332:33081:4332:33081) pci, 8139too, ETHERNET, RTL-8139/8139C/8139C+
:(4332:33128:4163:33478) pci, r8169, ETHERNET, M3A78-EH Motherboard
:(32902:10185:4163:33145) pci, uhci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:(32902:10184:4163:33145) pci, uhci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:(32902:10688:4163:33456) pci, agpgart-intel, HOST/PCI, P5KPL-VM Motherboard
:(32902:10186:4163:33145) pci, uhci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:(32902:10187:4163:33145) pci, uhci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:(32902:10188:4163:33145) pci, ehci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sdb1 / ext4 4096 4096 26186687 21594499 21332435 6553600 6244347 6244347
:/dev/sda3 WITHHELD ext4 4096 4096 217494244 91577150 80691458 54435840 54293707 54293707
:/dev/sdb3 WITHHELD ext4 4096 4096 217494244 58595148 47709456 54435840 54293217 54293217
:/dev/sda1 WITHHELD ext4 4096 4096 26186687 23814490 23552451 6553600 6323531 6323531
:

var_log_messages:
:Apr 28 17:45:07 mamdo abrt[4031]: Saved core dump of pid 4029 (/usr/bin/iok) to /var/spool/abrt/ccpp-2012-04-28-17:45:06-4029 (11309056 bytes)
:Apr 28 17:45:29 mamdo kernel: [30982.768327] iok[4057]: segfault at 327470 ip 4ac8e10d sp bfd0cc90 error 4 in libglib-2.0.so.0.3000.2[4ac2e000+120000]
:Apr 28 17:45:29 mamdo abrt[4059]: Saved core dump of pid 4057 (/usr/bin/iok) to /var/spool/abrt/ccpp-2012-04-28-17:45:29-4057 (11362304 bytes)

xsession_errors:
:*** glibc detected *** iok: malloc(): memory corruption (fast): 0x09ea1d68 ***
:iok[0x80637d2]
:iok[0x80684c2]
:iok[0x804b942]
:iok[0x804b9d9]
:08045000-08072000 r-xp 00000000 08:11 156699     /usr/bin/iok
:08072000-08073000 r--p 0002c000 08:11 156699     /usr/bin/iok
:08073000-08074000 rw-p 0002d000 08:11 156699     /usr/bin/iok
Comment 1 das 2012-04-28 09:11:17 EDT
Created attachment 580967 [details]
File: dso_list
Comment 2 das 2012-04-28 09:11:20 EDT
Created attachment 580968 [details]
File: maps
Comment 3 das 2012-04-28 09:11:25 EDT
Created attachment 580969 [details]
File: backtrace
Comment 4 Parag Nemade 2012-04-29 02:21:59 EDT
I am not able to reproduce this. Are you able to reproduce this? If yes then please provide what steps you followed when crash happened.

From backtrace, I see you ran iok in en locale and tried to use mni-inscript2-mtei keymap.
Comment 5 Parag Nemade 2012-06-28 06:23:14 EDT
No input provided.

Note You need to log in before you can comment on or make changes to this bug.