Bug 817276 - qemu on ARM aborts because of missing ucontext
qemu on ARM aborts because of missing ucontext
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-04-28 10:38 EDT by Richard W.M. Jones
Modified: 2012-05-04 19:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 16:18:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-glibc-Backport-ARM-implementation-of-ucontext-from-u.patch (15.94 KB, patch)
2012-04-28 10:39 EDT, Richard W.M. Jones
no flags Details | Diff

  None (edit)
Description Richard W.M. Jones 2012-04-28 10:38:09 EDT
Description of problem:

qemu on ARM aborts early on because it uses a home-brewed
coroutine implementation which relies on working getcontext/etc
functions.  On ARM these all return ENOSYS.

glibc-ports upstream has a patch which implements enough
ucontext functionality to get qemu working.

The attached patch backports this patch to Fedora glibc
(in Rawhide).

I compiled and tested glibc with this patch, and it
fixes the initial problem with qemu on ARM (although qemu
fails a bit later on for an unrelated reason).

Version-Release number of selected component (if applicable):

glibc-2.15-32.fc18.armv7hl

Additional info:

https://bugs.launchpad.net/qemu-linaro/+bug/883136
http://sourceware.org/ml/libc-ports/2012-02/msg00077.html

Upstream patch:

http://sourceware.org/git/?p=glibc-ports.git;a=commit;h=402a76b62dded0ee93cfec0471aaeccb989196d2
Comment 1 Richard W.M. Jones 2012-04-28 10:39:04 EDT
Created attachment 580976 [details]
0001-glibc-Backport-ARM-implementation-of-ucontext-from-u.patch
Comment 2 Adam Goode 2012-04-28 15:15:51 EDT
It looks like the patch is missing all the new files?
Comment 3 Richard W.M. Jones 2012-04-28 15:32:51 EDT
That's bizarre.  Here is the actual patch:

http://oirase.annexia.org/tmp/0001-glibc-Backport-ARM-implementation-of-ucontext-from-u.patch
Comment 4 Richard W.M. Jones 2012-04-28 15:33:25 EDT
Comment on attachment 580976 [details]
0001-glibc-Backport-ARM-implementation-of-ucontext-from-u.patch

See comment 3 for the real patch.
Comment 5 Jeff Law 2012-04-30 16:04:46 EDT
Installed into rawhide.  Do y'all need this in f17 as well?
Comment 6 Brendan Conoboy 2012-04-30 16:09:10 EDT
Please pull into F17 as well.
Comment 7 Jeff Law 2012-04-30 16:17:33 EDT
Done.  If there's a way I can test this, let me know...  My only verification was that what appear to be the right files appeared to be in the right place :-)
Comment 8 Fedora Update System 2012-05-01 15:51:22 EDT
glibc-2.15-35.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/glibc-2.15-35.fc17
Comment 9 Fedora Update System 2012-05-04 19:05:57 EDT
glibc-2.15-35.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.