Bug 81728 - default Mozilla GUI fonts hard to read
Summary: default Mozilla GUI fonts hard to read
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla
Version: phoebe
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-13 15:24 UTC by Michael Wardle
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-19 17:40:07 UTC


Attachments (Terms of Use)

Description Michael Wardle 2003-01-13 15:24:54 UTC
Description of problem:
When first starting Mozilla on a newly installed Red Hat Linux 8.0.92 system,
I notice the fonts are very small, serif, and quite hard to read.  The
default preferences should be changed to something like:

Proportional: Sans Serif
Serif: Luxi Serif
Sans Serif: Luxi Sans
Cursive: URW Chancery L
Fantasy: URW Gothic L
Monospace: Luxi Mono

Version-Release number of selected component (if applicable):
1.2.1-3

How reproducible:
Always

Steps to Reproduce:
1. Perform a clean install of Red Hat Linux 8.0.92 (phoebe)
2. Open the Mozilla Web browser
    
Actual results:
Fonts used in the GUI and document are both too small to reasonably read.
When viewing the Fonts preferences page (Edit->Preferences...
Appearance->Fonts), the default font style for proportional text is serif
and all font families are set to use Bitstream Charter.

Expected results:
Fonts are somewhat larger.  GUI fonts are sans-serif rather than serif to
be consistent with other applications' menus.  Each font family (serif,
sans-serif, etc.) has a reasonable default.

Additional info:
My screen resolution is 1280x1024 on a 17 inch monitor.

Comment 1 Sam Steingold 2003-01-15 15:17:03 UTC
actually the fonts are so hard to read because they are "anti-aliased", i.e.,
blurred on purpose to appear "pretty".
it would be nice to be able to disable this "feature".

Comment 2 Michael Wardle 2003-01-15 22:37:40 UTC
Please note that the description states I believe they are hard to read because
they are too small and serif rather than sans serif.  It is also to suggest that
Mozilla be configured to use the same default fonts as other GUI applications on
Red Hat Linux.

This bug is not intended to deal with anti-aliasing of text.


Comment 3 Christopher Blizzard 2003-01-19 17:40:07 UTC
This should be fixed in 1.2.1-8.


Note You need to log in before you can comment on or make changes to this bug.