Bug 817289 - Installation of kernel during preupgrade fails to update grub
Installation of kernel during preupgrade fails to update grub
Status: CLOSED DUPLICATE of bug 826537
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-28 12:51 EDT by Kaare Fiedler Christiansen
Modified: 2012-06-03 02:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-03 02:45:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaare Fiedler Christiansen 2012-04-28 12:51:50 EDT
Description of problem:

After using 'preupgrade' to upgrade from Fedora 16 to 17 grub wasn't updated with an entry for the new kernel

Version-Release number of selected component (if applicable):

kernel-3.3.2-8.fc17.x86_64
preupgrade-1.1.10-1.fc16.noarch

How reproducible:

Don't know. I only upgraded my system once :-)

Steps to Reproduce:
1. On a fully updated (per circa 2011-04-28T10:00:00Z), run preupgrade
2. Wait for upgrade to complete
  
Actual results:

Grub presents only old Fedora 16 kernel

Expected results:

Grub should present new Fedora 17 kernel

Additional info:

From the install.log I see the following:
"10:49:15 Upgrading kernel-3.3.2-8.fc17.x86_64
grubby fatal error: unable to find a suitable template"

Could it be that the preupgrade entry in grub interferes with the scripts?
Comment 1 Kaare Fiedler Christiansen 2012-04-28 15:46:28 EDT
I forgot to mention that uninstalling and reinstalling the kernel fixed the problem, leading me to believe that the grub.conf during preupgrade install somehow borked the postinstall scriplet.
Comment 2 Tim Flink 2012-05-22 20:04:18 EDT
Looks like a possible duplicate of #820340. Do you know what kernel version you were running on F16 before you ran preupgrade?
Comment 3 Kaare Fiedler Christiansen 2012-05-23 08:56:04 EDT
According to my yum history it was kernel-3.3.2-6.fc16.x86_64.
It shows no record of any fc16 kernels newer than kernel-3.3.2-8.fc17.x86_64.
Comment 4 Darryl L. Pierce 2012-06-01 09:39:36 EDT
On my system (F16->F17, x86_64 via preupgrade) I had both 3.3.7-1.fc16 and 3.3.7-1.fc17 installed on my system after preupgrade finished.
Comment 5 Kaare Fiedler Christiansen 2012-06-03 02:45:47 EDT
I'm closing this as a duplicate of #826537, where a fix seems to be underway.
I guess I really should have proposed this as a blocker, seeing how many people got hit by this bug.

*** This bug has been marked as a duplicate of bug 826537 ***

Note You need to log in before you can comment on or make changes to this bug.