Bug 81729 - JavaScript error on the query page
JavaScript error on the query page
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-13 10:25 EST by David Balažic
Modified: 2013-06-23 23:08 EDT (History)
0 users

See Also:
Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-02 15:35:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Balažic 2003-01-13 10:25:07 EST
Description of problem:

Browser ( netscape 4.8-win32 ) complain abaout javascript error.


Version-Release number of selected component (if applicable):

bugzilla 2.17.1

How reproducible:

Visit the query page.

go to https://bugzilla.redhat.com/bugzilla/query.cgi

Steps to Reproduce:
1. Start netscape
2. go to https://bugzilla.redhat.com/bugzilla/query.cgi
3. enter javascript: as new URL to get the error report
    
Actual results:

After loading the query page, a message is displayed in the status bar about a 
javascript error, suggesting entering "javascript:" as URL to get details. The 
details are :

JavaScript Error:
https://bugzilla.redhat.com/bugzilla/query.cgi, line 31:

selectProduct is not defined. 


Expected results:

no javascript error

Additional info:

Similar error under IE6.0SP1 ( both under win200pro SP3 ) for the same page :

Line: 30
Char: 1
Error: Object expected
Code: 0
URL: https://bugzilla.redhat.com/bugzilla/query.cgi
Comment 1 David Lawrence 2006-04-08 14:04:55 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 2 David Lawrence 2007-11-02 15:35:03 EDT
query.cgi has been completely revamped since this bug was occuring.  Please open
new report if any javascript errors are occurring.

Note You need to log in before you can comment on or make changes to this bug.