Bug 817317 - split out lsb_release in it's own package
split out lsb_release in it's own package
Status: CLOSED DUPLICATE of bug 835919
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-lsb (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Lawrence Lim
BaseOS QE - Apps
http://packages.debian.org/sid/lsb-re...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-28 20:28 EDT by Christoph Anton Mitterer
Modified: 2014-03-25 21:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 05:04:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Anton Mitterer 2012-04-28 20:28:31 EDT
Hi.

lsb_release is a generally useful tool, e.g. to easily and "portably" find out the running distribution and its version.

However, redhat-lsb depends on a huge pile of desktop crap (qt, cups, etc. pp.).

Please follow what e.g. Debian already does and split out lsb_release in a smallish base (lsb-relase) package with no further dependencies.


Cheers,
Chris.
Comment 2 Petr Šplíchal 2012-08-03 11:30:52 EDT
Could this be resolved by providing a separate redhat-lsb-core?
See also bug 835919.
Comment 3 Christoph Anton Mitterer 2012-08-03 18:23:10 EDT
I guess so.

What one needs is a package that has no further dependecies (especially not on any large stuff like Qt), which provides some core utilities of lsb.

As mentioned, have a look at what Debian provides in lsb-base and lsb-release.


Actually it's not only the lsb_release command that would be useful in a small standard package, but also e.g. /lib/lsb/init-functions
Uses also by many EPEL packages even though they don't depend correctly on the current big monolithic lsb package.
Comment 4 Petr Šplíchal 2012-08-14 05:04:25 EDT
(In reply to comment #3)
> Actually it's not only the lsb_release command that would be useful in a
> small standard package, but also e.g. /lib/lsb/init-functions
> Uses also by many EPEL packages even though they don't depend correctly on
> the current big monolithic lsb package.

Yes, I believe the new redhat-lsb-core package should include all
commands/functions currently present in redhat-lsb, just omit the
dependencies which will remain in redhat-lsb. Thanks for the info.

*** This bug has been marked as a duplicate of bug 835919 ***

Note You need to log in before you can comment on or make changes to this bug.