Bug 817320 - AR9285 still not working with kernel 3.3.2-6
AR9285 still not working with kernel 3.3.2-6
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
wireless first=3.3.2
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-28 22:54 EDT by Rafa
Modified: 2012-11-14 10:20 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 10:20:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafa 2012-04-28 22:54:06 EDT
Description of problem:

As said the kernel 3.3.2-6 will fix the Atheros Wifi card connection problem. I updated and still not working.

Version-Release number of selected component (if applicable):
Linux home 3.3.2-6.fc16.x86_64 #1 SMP Sat Apr 21 12:43:20 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

Update kernel.

Additional info:


# lspci
01:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast Ethernet (rev c1)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

# lsmod | grep ath9k
ath9k                 134768  0 
mac80211              496450  1 ath9k
ath9k_common           13600  1 ath9k
ath9k_hw              408211  2 ath9k,ath9k_common
ath                    23089  3 ath9k,ath9k_common,ath9k_hw
cfg80211              195558  3 ath9k,mac80211,ath

this configurations below were done in my attempts to make it works.

# ls /etc/modprobe.d/
ath9.conf  blacklist.conf  dist-alsa.conf  dist.conf  dist-oss.conf  openfwwf.conf_OLD  udlfb.conf
# cat /etc/modprobe.d/ath9.conf 
options ath9k nohwcrypt=1
# cat /etc/modprobe.d/openfwwf.conf_OLD 
options b43 nohwcrypt=1 qos=0


Wifi I'm tryng to connect to:

# iwconfig 
em1       no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"TheWifi"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 38:60:77:BA:13:C7   
          Bit Rate=54 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=70/70  Signal level=-26 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:17   Missed beacon:0

Any help it's really appreciated... I've been reading and everybody got this solved with the kernel update but me.

Thanks!
Comment 1 John W. Linville 2012-07-17 10:19:09 EDT
Can you post the output of "dmesg" shortly after a failed connection attempt?
Comment 2 Dave Jones 2012-10-23 11:33:38 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 3 Justin M. Forbes 2012-11-14 10:20:30 EST
With no response, we are closing this bug under the assumption that it is no longer an issue. If you still experience this bug, please feel free to reopen the bug report.

Note You need to log in before you can comment on or make changes to this bug.