Bug 817326 - SELinux is preventing /usr/bin/totem-video-thumbnailer from 'write' accesses on the directory /home/misha/.gstreamer-0.10.
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'write' accesses ...
Status: CLOSED DUPLICATE of bug 817321
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ce259791f9f6f593a0a34a755d6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-29 01:12 EDT by Misha Shnurapet
Modified: 2012-04-30 16:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 16:01:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha Shnurapet 2012-04-29 01:12:03 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.2-8.fc17.x86_64
time:           Вс. 29 апр. 2012 14:11:40

description:
:SELinux is preventing /usr/bin/totem-video-thumbnailer from 'write' accesses on the directory /home/misha/.gstreamer-0.10.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that totem-video-thumbnailer should be allowed write access on the .gstreamer-0.10 directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep totem-video-thu /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:samba_share_t:s0
:Target Objects                /home/misha/.gstreamer-0.10 [ dir ]
:Source                        totem-video-thu
:Source Path                   /usr/bin/totem-video-thumbnailer
:Port                          <Неизвестно>
:Host                          (removed)
:Source RPM Packages           totem-3.4.0-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-118.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.2-8.fc17.x86_64 #1 SMP Sat Apr 21
:                              12:44:25 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    Вс. 29 апр. 2012 12:17:06
:Last Seen                     Вс. 29 апр. 2012 12:17:07
:Local ID                      87cb83f9-816f-4651-88ee-6c3d1d714640
:
:Raw Audit Messages
:type=AVC msg=audit(1335669427.331:74): avc:  denied  { write } for  pid=4841 comm="totem-video-thu" name=".gstreamer-0.10" dev="sda4" ino=13090832 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:samba_share_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1335669427.331:74): arch=x86_64 syscall=open success=no exit=EACCES a0=120ed70 a1=c2 a2=180 a3=1 items=0 ppid=3104 pid=4841 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=totem-video-thu exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: totem-video-thu,thumb_t,samba_share_t,dir,write
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-04-30 16:01:15 EDT

*** This bug has been marked as a duplicate of bug 817321 ***

Note You need to log in before you can comment on or make changes to this bug.