Bug 81736 - Login is impossible after Russian installation
Login is impossible after Russian installation
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kbd (Show other bugs)
phoebe
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-13 11:35 EST by Need Real Name
Modified: 2007-04-18 12:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-07 15:04:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rules file which works for Cyrillic, Arabic, Hebrew, Hindu, etc. (5.26 KB, text/plain)
2003-01-31 09:50 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-01-13 11:36:02 EST
Description of problem:
If Russian is selected as installation language,
the graphic login prompt accepts only Cyrillic input.  
It is impossible to enter "root" at the login prompt,
and impossible to switch to English.  
So the system is essentially unusable.

How reproducible: Just choose Russian as installation language.


Steps to Reproduce:
1. Choose Russian as install language.
2. Accept all defaults.
3. Try to log in as root.
    
Actual results: When trying to log in, all keyboard input
is displayed in Cyrillic and it is impossible to type "root".


Expected results: English should be default input mode.


Additional info: RH 8.0 and all previous releases did not
display this behaviour.
Comment 1 Bill Nottingham 2003-01-15 02:04:09 EST
Russian map in kbd is not in unicode, as I recall.
Comment 2 Need Real Name 2003-01-31 09:50:44 EST
Created attachment 89739 [details]
Rules file which works for Cyrillic, Arabic, Hebrew, Hindu, etc.

The only change is that lines 16 and 17 are uncommented.
Comment 3 Need Real Name 2003-01-31 09:52:51 EST
This problem was caused because a new method was adopted for defining
key mappings for alphabets like Cyrillic, that use the upper 128 ASCII
characters.  This new method requires that non-Western layouts implicitly
include the standard en_US layout.  This is easily accomplished by
uncommenting two lines in the rules file /usr/X11R6/lib/X11/xkb/rules/xfree86.
But in implementing the new method, nobody uncommented these lines, and
apparently nobody tested it with non-Western alphabets.

The relevant text starts at line 14 of /usr/X11R6/lib/X11/xkb/rules/xfree86:
==============================================================================
// If you want non-latin layouts implicitly include the en_US layout
// uncomment lines below
//! $nonlatin = am ar ben bg by dev el ge_la ge_ru guj gur il il_phonetic\
//              ir iu mk mm ru sr th tj tml ua
==============================================================================
Uncommenting these lines will only affect these keyboard layouts:
Armenian, Arabic, Bengali, Bulgarian, Belorussian, Hindi, Greek, Georgian,
Gujarati, Gurmukhi, Hebrew, Iranian, Macedonian, Burmese, Russian, Serbian,
Thai, Tajik, Tamil and Ukrainian.  It will have no effect on Western languages.

Proposed Fix:
Uncomment lines 16 and 17 in the file /usr/X11R6/lib/X11/xkb/rules/xfree86:
==============================================================================
! $nonlatin = am ar ben bg by dev el ge_la ge_ru guj gur il il_phonetic\
              ir iu mk mm ru sr th tj tml ua
==============================================================================
Comment 4 Eido Inoue 2003-02-07 15:03:36 EST
fixed in the latest rawhide.

Note You need to log in before you can comment on or make changes to this bug.