Bug 817372 - Spacecmd configchannel_addfile displays the base64 encoded file on the screen
Spacecmd configchannel_addfile displays the base64 encoded file on the screen
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.8
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Steven Hardy
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-04-29 09:56 EDT by Trent Johnson
Modified: 2012-11-01 12:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 12:19:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trent Johnson 2012-04-29 09:56:05 EDT
Description of problem:

When using configchannel_addfile in spacecmd, if a file has a trailing newline, it is base64 encoded, and then the base64 encoding is dumped to stdout.  Since base64 encoding is not useful to humans, it is just added noise on the screen for no reason.


How reproducible:
run spacemd configchannel_addfile /path/to/a/text/file.txt

  
Actual results:
You will see a bunch of base64 encoded noise on the terminal after the upload is complete.

Expected results:
The file is not displayed at all, or a text representation is displayed

Additional info:
Comment 1 Steven Hardy 2012-05-15 12:25:04 EDT
Fixed by a2a351947e2721b5d23b08439e838df159fa2137

Please verify in next spacewalk-nightly spacecmd (1.8.6-1)
Comment 2 Jan Pazdziora 2012-10-30 15:24:32 EDT
Moving ON_QA. Packages that address this bugzilla should now be available in yum repos at http://yum.spacewalkproject.org/nightly/
Comment 3 Jan Pazdziora 2012-11-01 12:19:53 EDT
Spacewalk 1.8 has been released: https://fedorahosted.org/spacewalk/wiki/ReleaseNotes18

Note You need to log in before you can comment on or make changes to this bug.