Bug 817404 - libvirt/virsh (0.9.11.3) fails to create VM config
libvirt/virsh (0.9.11.3) fails to create VM config
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-29 16:00 EDT by Srini
Modified: 2012-05-06 12:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-06 12:45:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tar of guest domain xml config file and error files (11.18 KB, application/x-compressed-tar)
2012-04-29 16:00 EDT, Srini
no flags Details

  None (edit)
Description Srini 2012-04-29 16:00:45 EDT
Created attachment 581095 [details]
Tar of guest domain xml config file and error files

Description of problem:

There are two issues here:

1) with --with-numactl the cpu_map.xml path is hard-coded to the location of build for ex: /home/cloud/usr/share/libvirt/cpu_map.xml instead of the standard location /usr/local/share/libvirt/cpu_map.xml

2) VM config creation fails with the error shown below because of a segmentation violation by libvirtd (please look for Segmentation violation in either of the logs attached. A core file wasn't created though).

Version-Release number of selected component (if applicable):
$ libvirtd --version
libvirtd (libvirt) 0.9.11


How reproducible: 100 %


Steps to Reproduce:
1. configure libvirt as follows:
libvirt/virsh fails to create a VM config when configured as follows:
./configure --with-qemu --with-xen --with-uml --with-vmware --with-libssh2  --with-numactl --with-netcf --with-storage-fs --with-macvtap --with-virtualport
2. run the command virsh -c qemu://system create test3.xml

  
Actual results:
$ sudo virsh -c qemu:///system create /tmp/test3.xml 
error: End of file while reading data: Input/output error
error: failed to connect to the hypervisor


Expected results:
VM domain created successfully.

Additional info:
libvirt version: 0.9.11.3
Hardware: x86_64
hypervisor: qemu/kvm
Attached files:
tar of test3.xml (guest domain), cpu_map_errors.txt, log_errors.txt
Comment 1 Srini 2012-05-06 12:45:49 EDT
The issue was that there were multiple versions of libvirt and there was incompatibility of libvirt binaries with libvirt shared libraries which caused the binaries to run erratically.

Note You need to log in before you can comment on or make changes to this bug.