Bug 817405 - RFE: add option to have certmonger add IPA CA cert to NSS database
RFE: add option to have certmonger add IPA CA cert to NSS database
Status: CLOSED DUPLICATE of bug 767700
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: certmonger (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Nalin Dahyabhai
IDM QE LIST
: FutureFeature
Depends On: 759545
Blocks: 767700 1098208
  Show dependency treegraph
 
Reported: 2012-04-29 16:02 EDT by Dmitri Pal
Modified: 2014-05-15 09:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 759545
Environment:
Last Closed: 2013-05-07 11:12:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-04-29 16:02:45 EDT
+++ This bug was initially created as a clone of Bug #759545 +++

Description of problem:

It would be handy if ipa-getcert could have a option to fetch and install the IPA CA certificate into an NSS database when issuing a request.

This CA cert should be available locally in /etc/ipa/ca.crt for enrolled hosts or on the IPA server in /ipa/config/ca.crt (can be retrieved over HTTP).

--- Additional comment from nalin@redhat.com on 2011-12-02 15:02:15 EST ---

What would be the expected behavior in cases when the certificate and private key for a request were being stored in a flat file?

Most of the time the IPA CA certificate doesn't contain a friendlyName extension, so ipa-getcert would need to be told where the database is and which nickname to set for the CA certificate in the database.  At that point, what's the advantage of having ipa-getcert or certmonger do it instead of running certutil?

--- Additional comment from rcritten@redhat.com on 2011-12-02 15:27:35 EST ---

This would be for NSS databases only, flat file users are on their own.

The nickname format is '$REALM IPA CA'

ipa-getcert should already know the database location, right?

I think requested advantage is saving the user a step

You may be able to get away with documenting this in the man page.

--- Additional comment from dpal@redhat.com on 2011-12-03 13:17:25 EST ---

If it saves the step - great. Seems like an improvement to me that will save people time.

--- Additional comment from dpal@redhat.com on 2012-04-29 16:02:12 EDT ---

This step was not well documented in the manual procedure and users stumbled on it.
Comment 2 Jenny Galipeau 2013-05-07 11:12:15 EDT

*** This bug has been marked as a duplicate of bug 767700 ***

Note You need to log in before you can comment on or make changes to this bug.