Bug 817443 - RFE: SQL script for Skynet install
RFE: SQL script for Skynet install
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Matthew Casperson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-29 23:23 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 01:11:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-04-29 23:23:03 EDT
A Skynet installation requires a database with a specific schema.

It also requires specific data to be present (constants). 

Can I get a SQL script with the schema and the necessary data populated in order to spin up a Skynet instance.
Comment 1 Joshua Wulf 2012-05-03 10:04:38 EDT
Setting the priority and urgency to high. 

Needed for the FUDCon deployment before I can start testing it.

FUDCon is March 18, and I'd like to have it up a week ahead.
Comment 2 Lee Newson 2012-05-11 02:13:00 EDT
Since I talked to Josh and he's set it up using the live copy, however removing our topics, I'm gonna set this to low priority as it's probably still a good idea.
Comment 3 Matthew Casperson 2012-07-29 21:20:19 EDT
This is something that I am implementing with the next version at https://github.com/mcasperson/PressGangCCMSREST

The idea will be to use topics distributed in the system to document the system. To this end, basic tags like Concept, Task and Reference will be included in a deployment SQL script, along with categories and projects for the PressGang CCMS product.

What I need to know is what tags, categories, projects, string constants, images etc should be included in the default installation.
Comment 4 Matthew Casperson 2013-06-12 17:02:50 EDT
See https://github.com/pressgang-ccms/PressGangCCMSDeployable

CreateInitialDatabase.sql will copy across the minimum database rows into a new table.

import.sql is the minimum table exported.
Comment 5 Lee Newson 2013-10-09 01:11:14 EDT
Moving this bug to CLOSED CURRENT_RELEASE to clean up old bugs that were QA'd by the PressGang team but not by the original reporter.

Note You need to log in before you can comment on or make changes to this bug.