Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 817462 - plymouth disabled & removed but still tries to start
Summary: plymouth disabled & removed but still tries to start
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-30 06:51 UTC by Vladimir Rusinov
Modified: 2012-06-15 08:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-15 08:40:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Vladimir Rusinov 2012-04-30 06:51:55 UTC
Description of problem:

After removing plymouth systemd still tries to start plymouth-start.service on start (and plymouth-reboot.service on reboot). `systemctl disable  plymouth-start.service` does not helps.


Version-Release number of selected component (if applicable): F17, systemd-44-7.fc17.x86_64


How reproducible:


Steps to Reproduce:
1. Remove plymouth
2. Reboot
  
Actual results:

There's 'failed' message when starting plymouth-start.service

Expected results:

Plymouth does not tries to start => no errors reported. 

Additional info:

$ sudo systemctl status plymouth-start.service
plymouth-start.service - Show Plymouth Boot Screen
          Loaded: loaded (/usr/lib/systemd/system/plymouth-start.service; static)
          Active: failed (Result: exit-code) since Mon, 30 Apr 2012 10:36:47 +0400; 12min ago
          CGroup: name=systemd:/system/plymouth-start.service

Apr 30 10:36:47 bart (lymouthd)[470]: Failed at step EXEC spawning /sbin/plymouthd: No such file or directory


$ rpm -qa | grep plymouth
$ # no output 

$ rpm -qf /usr/lib/systemd/system/plymouth-start.service
systemd-44-7.fc17.x86_64

I believe /usr/lib/systemd/system/plymouth-start.service should belong to plymouth package, not systemd.

Comment 1 Michal Schmidt 2012-06-15 08:40:54 UTC
(In reply to comment #0)
> After removing plymouth systemd still tries to start plymouth-start.service
> on start (and plymouth-reboot.service on reboot). `systemctl disable 
> plymouth-start.service` does not helps.

plymouth-start.service has no [Install] section. It cannot be disabled this way. However, you can mask it: "systemctl mask plymouth-start.service".

> I believe /usr/lib/systemd/system/plymouth-start.service should belong to
> plymouth package, not systemd.

Yes. This is now fixed in Rawhide, where the plymouth unit files have been moved to the plymouth package.
I won't try to fix this in F17 though, because the bug's impact is low and there's a risk of breaking something in the move.


Note You need to log in before you can comment on or make changes to this bug.