Bug 817463 - Users must be able to use PyMol as default molecular viewer application
Users must be able to use PyMol as default molecular viewer application
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pymol (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Fenn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 02:55 EDT by Gökçen Eraslan
Modified: 2012-06-03 19:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-03 19:28:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing the issue (2.34 KB, patch)
2012-05-01 05:57 EDT, Gökçen Eraslan
no flags Details | Diff
Another patch fixing argument handling (544 bytes, patch)
2012-05-01 07:10 EDT, Gökçen Eraslan
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 335 None None None Never

  None (edit)
Description Gökçen Eraslan 2012-04-30 02:55:17 EDT
Description of problem:

PyMol application is able to display/parse a lot of file formats[1] including PDB[2], Fasta[3], xyz[4], SDF[5], MOL[6], MOL2[7] etc. It would be great to define those mimetypes in pymol.desktop file and use pymol as the default molecular viewer application.

This line defines according mimetypes:

MimeType=chemical/x-pdb;chemical/x-mdl-molfile;chemical/x-mol2;chemical/seq-aa-fasta;chemical/seq-na-fasta;chemical/x-xyz;chemical/x-mdl-sdf;

Some notes:

1- Also, it would be great to be able to open .pse pymol session files by double clicking but I don't know if they have any standard mimetypes defined.

2- Currently none of those mimetypes are defined in shared-mime-info[8] but in this bug report[9], it's still being discussed.


[1] http://www.pymolwiki.org/index.php/Load
[2] http://reference.wolfram.com/mathematica/ref/format/PDB.html
[3] http://reference.wolfram.com/mathematica/ref/format/FASTA.html
[4] http://reference.wolfram.com/mathematica/ref/format/XYZ.html
[5] http://reference.wolfram.com/mathematica/ref/format/SDF.html
[6] http://reference.wolfram.com/mathematica/ref/format/MOL.html
[7] http://reference.wolfram.com/mathematica/ref/format/MOL2.html
[8] http://cgit.freedesktop.org/xdg/shared-mime-info/tree/freedesktop.org.xml.in
[9] https://bugs.freedesktop.org/show_bug.cgi?id=335

Version-Release number of selected component (if applicable):
pymol-1.5.0.2-1.20120218svn3982.fc17.x86_64
Comment 1 Tim Fenn 2012-04-30 03:01:11 EDT
Sure thing - I'll look into this, but patches are certainly welcome!
Comment 2 Gökçen Eraslan 2012-05-01 05:57:26 EDT
Created attachment 581340 [details]
Patch fixing the issue

Validate, correct desktop file and add mimetypes. Also chemical-mime-data is needed to define chemical/* mimetypes.
Comment 3 Gökçen Eraslan 2012-05-01 06:33:34 EDT
By the way, source tarball has .svn directories. Why? Any reason to not using "svn export" command?
Comment 4 Gökçen Eraslan 2012-05-01 07:10:01 EDT
Created attachment 581353 [details]
Another patch fixing argument handling

I have discovered another bug while playing with this patch. Following command does not work:

pymol "some dir with space/1KJF.pdb" 

since pymol wrapper is written as:

/usr/bin/python /usr/lib64/python2.7/site-packages/pymol/__init__.py $*

This expands to:

/usr/bin/python /usr/lib64/python2.7/site-packages/pymol/__init__.py some dir with space/1KJF.pdb

which is wrong. pymol 4 parameters in this case, instead of 1.

Correct wrapper must be:

/usr/bin/python /usr/lib64/python2.7/site-packages/pymol/__init__.py "$@"

to hand arguments including spaces correctly[1]. Patch is attached.

[1] http://www.thegeekstuff.com/2010/05/bash-shell-special-parameters/
Comment 5 Fedora Update System 2012-05-08 22:50:34 EDT
pymol-1.5.0.2-2.20120218svn3982.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/pymol-1.5.0.2-2.20120218svn3982.fc16
Comment 6 Fedora Update System 2012-05-08 22:50:43 EDT
pymol-1.5.0.2-2.20120218svn3982.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/pymol-1.5.0.2-2.20120218svn3982.fc17
Comment 7 Tim Fenn 2012-05-08 22:52:23 EDT
(In reply to comment #3)
> By the way, source tarball has .svn directories. Why? Any reason to not using
> "svn export" command?

Oops, I'll fix this the next time a do a pull.  Sorry!
Comment 8 Fedora Update System 2012-05-09 12:10:47 EDT
Package pymol-1.5.0.2-2.20120218svn3982.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pymol-1.5.0.2-2.20120218svn3982.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7519/pymol-1.5.0.2-2.20120218svn3982.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-06-03 19:28:15 EDT
pymol-1.5.0.2-2.20120218svn3982.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-06-03 19:34:51 EDT
pymol-1.5.0.2-2.20120218svn3982.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.