This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 81748 - TrueType fonts below 8pt don't get rendered if bytecode interpreter is enabled
TrueType fonts below 8pt don't get rendered if bytecode interpreter is enabled
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: freetype (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Owen Taylor
Brock Organ
:
: 81747 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-13 13:07 EST by Felipe Alfaro Solana
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-13 18:55:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felipe Alfaro Solana 2003-01-13 13:07:10 EST
Description of problem:
-----------------------
Freetype has an internal bytecode interpreter that is disabled by default due to
patents. However, you can enable the bytecode interpeter by changing the spec
file from the SRPM package (please, see the repro steps for details).

If you rebuild the package (using rpmbuild -ba *.spec) and then install this new
version of freetype, some programs like OpenOffice are unable to properly render
TrueType fonts with a point size below 8pt (using a 100% zoom). Instead, nothing
is rendered.

This doesn't happen with freetype-2.1.2-12.src.rpm.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
freetype-2.1.3-4.src.rpm

How reproducible:
-----------------
Always, I have reproduced this on Red Hat 7.3 and Red Hat 8.0 using the
OpenOffice package that comes with Red Hat 8.0 (openoffice-1.0.1-8).

Steps to Reproduce:
1. Download freetype-2.1.3-4.src.rpm from RawHide
2. Modify the freetype.spec file that comes bundled inside this SRPM and modify
the line that reads:

%define without_bytecode_interpreter    1

to

%define without_bytecode_interpreter    0

3. Next, do an "rpmbuild -ba freetype.spec"
4. Once the package is built, do an "rpm -Uvh freetype-*" to upgrade/install the
new freetype package you have just compiled
5. Now, make sure openoffice-1.0.1-8.i386.rpm package is installed
6. Run OpenOffice
7. Type in some text at 6pt and you will see nothing is rendered. However, if
you choose 10pt, for example, the text is drawn with an excellent quality.
    
Actual results:
---------------
Using freetype-2.1.3-4.src.rpm recompiled with support for the built-in bytecode
interpreter, makes TrueType fonts at 8pt or less invisible!

Expected results:
-----------------
Enabling the internal bytecode interpreter should render TrueTypes fonts at any
point size.

Additional info:
----------------
This seems to affect freetype-2.1.3-3.src.rpm and freetype-2.1.3-4.src.rpm, as I
haven't been able to reproduce on freetype-2.1.12-12.src.rpm :-?
Comment 1 Felipe Alfaro Solana 2003-01-13 13:07:11 EST
Description of problem:
-----------------------
Freetype has an internal bytecode interpreter that is disabled by default due to
patents. However, you can enable the bytecode interpeter by changing the spec
file from the SRPM package (please, see the repro steps for details).

If you rebuild the package (using rpmbuild -ba *.spec) and then install this new
version of freetype, some programs like OpenOffice are unable to properly render
TrueType fonts with a point size below 8pt (using a 100% zoom). Instead, nothing
is rendered.

This doesn't happen with freetype-2.1.2-12.src.rpm.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
freetype-2.1.3-4.src.rpm

How reproducible:
-----------------
Always, I have reproduced this on Red Hat 7.3 and Red Hat 8.0 using the
OpenOffice package that comes with Red Hat 8.0 (openoffice-1.0.1-8).

Steps to Reproduce:
1. Download freetype-2.1.3-4.src.rpm from RawHide
2. Modify the freetype.spec file that comes bundled inside this SRPM and modify
the line that reads:

%define without_bytecode_interpreter    1

to

%define without_bytecode_interpreter    0

3. Next, do an "rpmbuild -ba freetype.spec"
4. Once the package is built, do an "rpm -Uvh freetype-*" to upgrade/install the
new freetype package you have just compiled
5. Now, make sure openoffice-1.0.1-8.i386.rpm package is installed
6. Run OpenOffice
7. Type in some text at 6pt and you will see nothing is rendered. However, if
you choose 10pt, for example, the text is drawn with an excellent quality.
    
Actual results:
---------------
Using freetype-2.1.3-4.src.rpm recompiled with support for the built-in bytecode
interpreter, makes TrueType fonts at 8pt or less invisible!

Expected results:
-----------------
Enabling the internal bytecode interpreter should render TrueTypes fonts at any
point size.

Additional info:
----------------
This seems to affect freetype-2.1.3-3.src.rpm and freetype-2.1.3-4.src.rpm, as I
haven't been able to reproduce on freetype-2.1.12-12.src.rpm :-?
Comment 2 Felipe Alfaro Solana 2003-01-13 13:11:13 EST
*** Bug 81747 has been marked as a duplicate of this bug. ***
Comment 3 Owen Taylor 2003-01-13 18:55:15 EST
"Not our problem". We don't ship the byte code interpreter, we don't
test the byte code interpreter, it's not clear I can even legally work
on the byte code interpreter.

Note You need to log in before you can comment on or make changes to this bug.