Bug 817485 - ERROR: policydb magic number 0x000008 does not match expected magic number 0xf97cff8c or 0xf97cff8d
ERROR: policydb magic number 0x000008 does not match expected magic number 0x...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 04:54 EDT by Jacek Pliszka
Modified: 2012-05-07 16:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 15:09:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/spool/abrt/pyhook-2012-04-26-20\:44\:40-1683 (1.10 KB, application/x-gzip)
2012-04-30 04:54 EDT, Jacek Pliszka
no flags Details

  None (edit)
Description Jacek Pliszka 2012-04-30 04:54:33 EDT
Created attachment 581154 [details]
/var/spool/abrt/pyhook-2012-04-26-20\:44\:40-1683

Description of problem:

Error messages in /var/log/messages:
dbus-daemon[873]: ERROR: policydb magic number 0x000008 does not match expected magic number 0xf97cff8c or 0xf97cff8d
dbus-daemon[873]: ERROR: Unable to open policy /sys/fs/selinux/policy.



Version-Release number of selected component (if applicable):
abrt-dbus-2.0.10-1.fc17.x86_64
dbus-1.4.10-4.fc17.x86_64


How reproducible:
It is just there in the /var/log/messages

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:



Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: dbus[920]: [system] Activating service name='org.fedoraproject.Setroubleshootd' (using servicehelper)
Apr 29 18:34:36 jpliszka3 dbus[920]: [system] Activating service name='org.fedoraproject.Setroubleshootd' (using servicehelper)
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: ERROR: policydb magic number 0x000008 does not match expected magic number 0xf97cff8c or 0xf97cff8d
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: ERROR: Unable to open policy /sys/fs/selinux/policy.
Apr 29 18:34:36 jpliszka3 abrt: detected unhandled Python exception in '/usr/sbin/setroubleshootd'
Apr 29 18:34:36 jpliszka3 abrtd: New client connected
Apr 29 18:34:36 jpliszka3 abrtd: Directory 'pyhook-2012-04-29-18:34:36-26547' creation detected
Apr 29 18:34:36 jpliszka3 abrt-server[26550]: Saved Python crash dump of pid 26547 to /var/spool/abrt/pyhook-2012-04-29-18:34:36-26547
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: Traceback (most recent call last):
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: File "/usr/sbin/setroubleshootd", line 97, in <module>
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: from setroubleshoot.server import RunFaultServer
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: File "/usr/lib64/python2.7/site-packages/setroubleshoot/server.py", line 46, in <module>
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: from setroubleshoot.analyze import (PluginReportReceiver,
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: File "/usr/lib64/python2.7/site-packages/setroubleshoot/analyze.py", line 37, in <module>
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: from setroubleshoot.avc_audit import *
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: File "/usr/lib64/python2.7/site-packages/setroubleshoot/avc_audit.py", line 38, in <module>
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: from setroubleshoot.util import *
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: File "/usr/lib64/python2.7/site-packages/setroubleshoot/util.py", line 283, in <module>
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: file_types =  setools.seinfo(setools.ATTRIBUTE,"file_type")[0]["types"]
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: File "/usr/lib64/python2.7/site-packages/setools/__init__.py", line 49, in seinfo
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: dict_list = _seinfo.seinfo(setype, name)
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: RuntimeError: Success
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: dbus[920]: [system] Activated service 'org.fedoraproject.Setroubleshootd' failed: Launch helper exited with unknown return code 1
Apr 29 18:34:36 jpliszka3 dbus[920]: [system] Activated service 'org.fedoraproject.Setroubleshootd' failed: Launch helper exited with unknown return code 1
Apr 29 18:34:36 jpliszka3 dbus[920]: [system] Activating service name='org.fedoraproject.Setroubleshootd' (using servicehelper)
Apr 29 18:34:36 jpliszka3 dbus-daemon[920]: dbus[920]: [system] Activating service name='org.fedoraproject.Setroubleshootd' (using servicehelper)
Apr 29 18:34:36 jpliszka3 abrtd: Duplicate: UUID
Apr 29 18:34:36 jpliszka3 abrtd: DUP_OF_DIR: /var/spool/abrt/pyhook-2012-04-26-20:44:40-1683
Apr 29 18:34:36 jpliszka3 abrtd: Problem directory is a duplicate of /var/spool/abrt/pyhook-2012-04-26-20:44:40-1683
Apr 29 18:34:36 jpliszka3 abrtd: Deleting problem directory pyhook-2012-04-29-18:34:36-26547 (dup of pyhook-2012-04-26-20:44:40-1683)
Comment 1 Daniel Walsh 2012-05-07 15:09:46 EDT
yum -y update setools-console
Comment 2 Jacek Pliszka 2012-05-07 16:40:38 EDT
yum  install setools-console

setools-console is not installed by default from LiveCD
Comment 3 Daniel Walsh 2012-05-07 16:52:53 EDT
yum -y update  setools-libs-python

Note You need to log in before you can comment on or make changes to this bug.