Bug 817567 - rhn_check does not correctly report the result of attempting to update an already updated package
Summary: rhn_check does not correctly report the result of attempting to update an alr...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-rhn-plugin   
(Show other bugs)
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Milan Zázrivec
QA Contact: Matej Kollar
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-30 14:14 UTC by Felix Dewaleyne
Modified: 2018-11-27 20:10 UTC (History)
3 users (show)

Fixed In Version: yum-rhn-plugin-0.9.1-40.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 12:00:26 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0752 normal SHIPPED_LIVE rhn-client-tools and yum-rhn-plugin bug fix and enhancement update 2012-06-19 19:31:17 UTC

Description Felix Dewaleyne 2012-04-30 14:14:12 UTC
Description of problem:
rhn_check reports the attempt to update packages already updated as a failure from time to time

Version-Release number of selected component (if applicable):
seen on 
rhn-client-tools.noarch                       1.0.0-73.el6

How reproducible:
all the time

Steps to Reproduce:
1. install a RHEL6.0 or 6.1 and register to rhn (package list needs to be uploaded)
2. update yum*, *rhn*, *rpm* to the latest version 
3. disabled rhnsd 
4. on rhn, enable the automatic installation of erratas
4. update the system to the latest version using yum ; do not update profile information. (we consider customers may want to do this to apply high level security erratas, but this is the best way to see the problem on a global scale)
5. enable the automatic installation of erratas
6. either wait for rhnsd to pick the job or run rhn_check with no debug option
  
Actual results:
on rhn the event list will list a lot of the installations as "failed" 

Expected results:
on rhn the packages already updated should show in the history as "passed".

Additional info:
the reproducer is wider than the usage of the customer on purpose. a customer may want only to install critical erratas before the job is picked from rhn as per policies or other reasons, and the events from automated errata installation will be "failed" erroneously for some of these.

Comment 2 Milan Zázrivec 2012-05-02 14:50:12 UTC
spacewalk.git master: eaca0fa4b2a602d8faea0d0f1848c83574d9865f

Comment 6 Matej Kollar 2012-05-04 11:19:30 UTC
Reproduced:

  new (child)channel "TestChannel" with dummy packages

    zsh-5.0.0-1
    zsh-dev-5.0.0.1

  client subscribed to this channel,
  zsh + zsh-dev installed with yum (so server knew about packages)
  new (child)channel "TestChannel2" with dummy packages

    zsh-5.0.1-1
    zsh-dev-5.0.1.1

  + erratum containing this two dummy packages
  (published erratum)
  client subscribed to TestChannel2
  installed (.rpm) packages with rpm (so server didn't know about it)
  scheduled errata application
  # rhn_check -vv

(even "reschedule" led to fail).

After upgrade to yum-rhn-plugin-0.9.1-40.el6 reschedule went ok.
Redoing described scenario worked ok.

Also checked that via WebUI scheduled installs & updates are working.
(With both rhn_check and with osad.)

Comment 8 errata-xmlrpc 2012-06-20 12:00:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0752.html


Note You need to log in before you can comment on or make changes to this bug.