Bug 817576 - prefer stable version of lilypond (2.14.2/2.16.x/2.18.x) instead of unstable/devel. versions
prefer stable version of lilypond (2.14.2/2.16.x/2.18.x) instead of unstable/...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lilypond (Show other bugs)
17
All All
unspecified Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 10:24 EDT by Martin Tarenskeen
Modified: 2012-05-01 08:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 10:35:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Tarenskeen 2012-04-30 10:24:13 EDT
Description of problem:


Version-Release number of selected component (if applicable):

lilypond 2.15.x (unstable) vs 2.14.2 (stable) vs. 2.16.x (stable, hopefully coming soon)

Additional info:

Instead of packaging an unstable 2.15.x version of lilypond in Fedora 17, which is updated upstream every two weeks or so, I'd prefer if Fedora would package 2.16.x when it comes out (probably soon) and then wait for the next stable version 2.18.x in the future.

Not a real bug report, more a request/suggestion.

-- 

MT
Comment 1 Gwyn Ciesla 2012-04-30 10:35:38 EDT
Normally I'd agree, but in this case I moved to the unstable branch because at the time the stable branch no longer built on rawhide.  As it is, we expect the next stable to come out prior to F17 GA, so I'll either get it in as an update or it will be in F17.  We've done this in the past with things like Firefox.
Comment 2 Pavel Roskin 2012-04-30 22:13:07 EDT
The compilation problem in Lilypond 2.14.2 is very minor.  The new compiler complains that the same variable "s" is redeclared.  The fix is to rename the inner "s" to "start".  It was fixed in the commit c95a76f15bb0ab0960ed7783762611254cabbd91 in the Lilypond git repository, which applies to Lilypond 2.14.2 as is (with patch --ignore-whitespace).
Fedora uses very recent versions of gcc, so it should be expected that things would break because of that.  A large project will likely have some little piece of code that the next gcc won't like.  Going to the unstable version because of one shadowed variable is an overkill IMHO.
Sure, the development version of Lilypond produces nicer PDF and MIDI files.  On the other hand, Lilypond files are text files that are meant to be edited and exchanged.  A Fedora 17 user would be in a position of a snob whose files won't work with the latest stable Lilypond.  convert-ly only works forwards, it doesn't backport Lilypond files.
Comment 3 Gwyn Ciesla 2012-05-01 08:31:40 EDT
All true, and I completely understand where you're coming from, but I rebased on 2.15.x in October, and only in rawhide.  The commit fixing the build issue was in December.  All stable, current releases of Fedora are still on 2.14.x.  If current schedules are accurate, Lilypond 2.16.x will be the stable release on 5/3, and Fedora 17 will be released 5/22, by which point it will have 2.16.x, rather than 2.15.x.

After release, a Fedora 17 user will be using the latest stable Lilypond.  Prior to release, a Fedora 17 user using not only a development release of Lilypond, but of Fedora as well.

Fedora rawhide and prerelease versions are for testing.  That's what we've been doing, and why I've been keeping rawhide up to date with the testing Lilypond releases, precisely to expand the Lilypond testing user base.

Note You need to log in before you can comment on or make changes to this bug.