Bug 817579 - [regression] Telepathy Rakia does not allow empathy SIP accounts to connect
[regression] Telepathy Rakia does not allow empathy SIP accounts to connect
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: telepathy-rakia (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 10:39 EDT by Jean-François Fortin Tam
Modified: 2013-02-15 16:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 22:44:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug log (2.21 KB, text/x-log)
2012-04-30 10:39 EDT, Jean-François Fortin Tam
no flags Details

  None (edit)
Description Jean-François Fortin Tam 2012-04-30 10:39:15 EDT
Created attachment 581199 [details]
debug log

I use SIP accounts for VoIP in Empathy, connecting to various SIP servers. In Fedora 16, this works. In Fedora 17, rakia is unable to connect.

Take a look at the debug log attached. The following line makes me suspect that something was incorrectly packaged or compiled out:

> DEBUG: nta: bind(0:*;transport=*): Protocol not supported
Comment 1 Brian Pepple 2012-04-30 10:54:30 EDT
This is a known problem, and will be fixed when the call branch of rakia is merged and released.

http://lists.freedesktop.org/archives/telepathy/2012-April/006078.html
Comment 2 Fedora Update System 2012-05-10 10:46:54 EDT
telepathy-rakia-0.7.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/telepathy-rakia-0.7.4-1.fc17
Comment 3 Fedora Update System 2012-05-10 16:38:01 EDT
Package telepathy-rakia-0.7.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing telepathy-rakia-0.7.4-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7599/telepathy-rakia-0.7.4-1.fc17
then log in and leave karma (feedback).
Comment 4 Jean-François Fortin Tam 2012-05-11 10:05:09 EDT
Hi Brian,
I still get the same problem with telepathy-rakia-0.7.4-1.fc17 from updates-testing.
Comment 5 Nicolas Dufresne 2012-05-23 15:17:58 EDT
In sofia-sip package, removing option --enable-sctp make it work again.
Comment 6 Brian Pepple 2012-05-24 14:36:39 EDT
Thanks for the information, Nicolas! I'll rebuilt sofia-sip, and will add it to the tp-rakia update. Jean-Francois, if you could test it, that would be great. Thanks.
Comment 7 Fedora Update System 2012-05-26 03:25:22 EDT
Package telepathy-rakia-0.7.4-1.fc17, sofia-sip-1.12.11-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing telepathy-rakia-0.7.4-1.fc17 sofia-sip-1.12.11-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7599/sofia-sip-1.12.11-3.fc17,telepathy-rakia-0.7.4-1.fc17
then log in and leave karma (feedback).
Comment 8 Jean-François Fortin Tam 2012-05-28 11:17:21 EDT
The SIP accounts now connect to the server.
Calls don't work, but that's a completely separate issue AFAIK.
Comment 9 Daniele Viganò 2012-06-05 10:27:27 EDT
I can confirm that the package in "updates-testing" resolved the issue about connecting to a SIP server using Empathy (was not working after a fresh Fedora 17 installation).

Thanks
Comment 10 Fedora Update System 2012-06-06 22:44:37 EDT
telepathy-rakia-0.7.4-1.fc17, sofia-sip-1.12.11-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Andrew Ter-Grigoryan 2013-02-14 15:02:22 EST
SIP account setup not working for me in F18. The host I tried it with is ekiga.net. It's possible (but unlikely) that it's a problem with them, since I also tried SIP account setup in Ekiga. Nothing has worked so far.
Comment 12 Nicolas Dufresne 2013-02-14 15:53:04 EST
Works for me using freeswitch server.
Comment 13 Andrew Ter-Grigoryan 2013-02-14 22:46:10 EST
(In reply to comment #12)
> Works for me using freeswitch server.

Could you please provide more information about the host that worked for you? Give me a URL I can use to register.

Ekiga SIP wouldn't even work with Ekiga, which is just sad.
Comment 14 Jean-François Fortin Tam 2013-02-15 15:06:35 EST
If ekiga.net doesn't even work with Ekiga, then the problem is the ekiga.net server, this has nothing to do with telepathy-rakia. In my case, the voip.ms servers work fine with telepathy-rakia in F18 now.
Comment 15 Andrew Ter-Grigoryan 2013-02-15 15:31:16 EST
SIP did work with another host (namely iptel.org).

Now I'm going to file a separate request for telepathy-rakia to be a default package in fedora. SIP is an important protocol.
Comment 16 Nicolas Dufresne 2013-02-15 16:39:45 EST
Yes, it also work for me
Comment 17 Nicolas Dufresne 2013-02-15 16:40:17 EST
Sorry, I mean it works for me with iptel.org.

Note You need to log in before you can comment on or make changes to this bug.