Bug 817630 - engine-manage-domains does not query IPA user correctly
engine-manage-domains does not query IPA user correctly
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: lpeer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 12:52 EDT by Yair Zaslavsky
Modified: 2015-03-04 19:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 12:58:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yair Zaslavsky 2012-04-30 12:52:20 EDT
Description of problem:

Based on disccussion at #ovirt, and some wireshark capture, it can be see that altough a user has provider -provider=ipa, the query used to obtain the user information used sAMAccountType=805306368 which is used for active-directory and not IPA, as a result, no IPA user was retrieved.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Yair Zaslavsky 2012-04-30 12:58:06 EDT
Not a bug, the user used an old version of engine-manage-domains.
This is a known issue (as defaultNamingContext wrongly caused him auto-detection of ActiveDirectory, and -provider did not exist in that version)

Note You need to log in before you can comment on or make changes to this bug.