Bug 817635 - nm-online failed to start, hung on shutdown and breaks connectivity on startup
nm-online failed to start, hung on shutdown and breaks connectivity on startup
Status: CLOSED DUPLICATE of bug 815091
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 13:30 EDT by Artemy Kapitula, RCNTEC Ltd
Modified: 2012-04-30 22:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 22:50:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artemy Kapitula, RCNTEC Ltd 2012-04-30 13:30:26 EDT
Description of problem:

When NetworkManager-wait-online service failed to start on Dell notebook. On boot, system hang for a 30 seconds while trying to start NetworkManager-wait-online.service systemd unit. When 30 second expires, system continue to boot, but there are no WiFi connections until relaoding WiFi card driver (rmmod iwl3945; modprobe iwl3945 in my case) or switching wireless adapater on-off with hardware switch. On reboot, system hung and doesn't poweroff or reboot.

Version-Release number of selected component (if applicable):

NetworkManager-0.9.4.0-7.git20120403.fc17.x86_64

Additional info:

I tried to clean all information about WiFi networks, but it gives me no effect.

Then, I tried to disable service with systemctl (systemtl disable NetworkManager wait-online.service) but it doesn't give any effect or me too - on boot, system again waits on this unit, failes unit and then hung on startup. To escape problem, I removed /lib/systemd/system/NetworkManager-wait-online.service and this solved a problem:

No hung on startup
No hung at shutdown
After boot WiFi network connection activated if known network is available
Comment 1 Bill Nottingham 2012-04-30 22:50:29 EDT

*** This bug has been marked as a duplicate of bug 815091 ***

Note You need to log in before you can comment on or make changes to this bug.